Highcharts Grid Pro: cell-renderer attributes map written with raw setAttribute
CVE-2026-116797GHSA-5ghw-9mgr-jvx2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@highcharts/grid-pro 3.2.0; @highcharts/dashboards 4.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.0.0, < 3.2.0
- Fixed in
- 3.2.0
- Affected
- >= 3.6.0, < 4.0.0
- Fixed in
- 4.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5ghw-9mgr-jvx2 lists affected ranges: npm @highcharts/grid-pro >=2.0.0 =3.6.0 <=3.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5ghw-9mgr-jvx2 lists affected ranges: npm @highcharts/grid-pro >=2.0.0 =3.6.0 <4.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-116797: 0.32% estimated exploitation activity in the next 30 days; percentile 24.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The input-type cell renderers copy every entry of the renderer's `attributes` option onto the input or select element they create, without checking the attribute names. An attacker who controls the Grid configuration can supply entries under a column's `cells.renderer.attributes` or `cells.editMode.renderer.attributes` whose names are event handlers, and those handlers execute in the origin of the page hosting the Grid. A view renderer places the handler on the input rendered in every row of the column as soon as the Grid renders; an edit-mode renderer places it on the input created when a cell enters edit mode, and that input is focused immediately, so a `focus` handler runs as soon as the user starts editing. Exploitation requires that untrusted data reach the Grid configuration and that a user hover over or focus one of the rendered inputs, or begin editing a cell. The Pro DataGrid that shipped inside the Dashboards package is included.
Workarounds If your column…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-5ghw-9mgr-jvx2
- Revision 1 · created ·
Published from ghsa record GHSA-5ghw-9mgr-jvx2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-116797 Advisory: Highcharts Grid Pro: cell-renderer `attributes` map written with raw `setAttribute` IDs: CVE-2026-116797, GHSA-5ghw-9mgr-jvx2 Record: https://patchnext.com/advisories/cve-2026-116797 (revision 2, source checked 29 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @highcharts/grid-pro 3.2.0; @highcharts/dashboards 4.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @highcharts/grid-pro: affected >= 2.0.0, < 3.2.0; fixed in 3.2.0 - npm @highcharts/dashboards: affected >= 3.6.0, < 4.0.0; fixed in 4.0.0 ## Suggested inspection (read-only) - `npm ls @highcharts/grid-pro --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @highcharts/dashboards --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @highcharts/grid-pro, @highcharts/dashboards. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5ghw-9mgr-jvx2 (GitHub-reviewed advisory GHSA-5ghw-9mgr-jvx2 lists affected ranges: npm @highcharts/grid-pro >=2.0.0 =3.6.0 <=3.6.0) - Verified: https://osv.dev/vulnerability/GHSA-5ghw-9mgr-jvx2 (OSV record GHSA-5ghw-9mgr-jvx2 lists affected ranges: npm @highcharts/grid-pro >=2.0.0 =3.6.0 <4.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…