Skip to content

← Actionable
High, CVSS 7.2amended

Highcharts Core: javascript: URL in an xlink:href attribute survives text filtering and reaches exported charts

CVE-2026-116796GHSA-mw4f-gj5x-6xr4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (highcharts 13.1.1, 12.6.2, 11.4.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm highcharts

    Affected
    >= 10.3.2, < 11.4.9>= 12.0.0, < 12.6.2>= 13.0.0, < 13.1.1
    Fixed in
    12.6.2, 11.4.9, 13.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-116796: 0.34% estimated exploitation activity in the next 30 days; percentile 27.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The filter applied to markup in text options checks `href`, `src` and a few similar attributes against an allowed-scheme list, but accepts `xlink:href` without that check, so an SVG anchor whose `xlink:href` is a `javascript:` URL passes the filter, whether or not the option is rendered with `useHTML`. In the live page the attribute is written without the XLink namespace, so browsers do not treat the anchor as a link there. The attribute is preserved verbatim in the chart's serialised output: the SVG produced by the exporting module, including the default SVG download, declares the XLink namespace and contains the anchor, and so does the markup of the chart container. Any document that parses that output again, such as the downloaded SVG opened in a browser or a page that inlines exported or server-rendered chart markup, then holds a working link, and an attacker who controls the chart configuration can thereby run script in the origin of that document when a user…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-mw4f-gj5x-6xr4

  2. Revision 1 · created ·

    Published from ghsa record GHSA-mw4f-gj5x-6xr4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116796

Advisory: Highcharts Core: `javascript:` URL in an `xlink:href` attribute survives text filtering and reaches exported charts
IDs: CVE-2026-116796, GHSA-mw4f-gj5x-6xr4
Record: https://patchnext.com/advisories/cve-2026-116796 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: highcharts 13.1.1, 12.6.2, 11.4.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm highcharts: affected >= 10.3.2, < 11.4.9; >= 12.0.0, < 12.6.2; >= 13.0.0, < 13.1.1; fixed in 12.6.2, 11.4.9, 13.1.1

## Suggested inspection (read-only)
- `npm ls highcharts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on highcharts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mw4f-gj5x-6xr4 (GitHub-reviewed advisory GHSA-mw4f-gj5x-6xr4 lists affected ranges: npm highcharts >=10.3.2 =12.0.0 =13.0.0 <=13.1.0)
- Verified: https://osv.dev/vulnerability/GHSA-mw4f-gj5x-6xr4 (OSV record GHSA-mw4f-gj5x-6xr4 lists affected ranges: npm highcharts >=10.3.2 =12.0.0 =13.0.0 <13.1.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…