Skip to content

← Actionable
Medium, CVSS 6.3amended

OpenTelemetry Python: Unbounded memory allocation in Jaeger baggage propagation

CVE-2026-116694GHSA-f5m9-jfrj-jjj7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (opentelemetry-propagator-jaeger 1.45.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-116694: 0.38% estimated exploitation activity in the next 30 days; percentile 31.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `JaegerPropagator.extract()` in `opentelemetry-propagator-jaeger` did not enforce limits when extracting inbound `uberctx-*` baggage headers. Attacker-controlled baggage could cause unnecessary CPU work and short-lived heap allocations while processing more data than the propagator should accept.

Impact Services that enable the optional Jaeger propagator and accept untrusted inbound propagation headers may experience increased per-request resource usage. This can contribute to denial-of-service risk when transport-level limits are absent or configured above the baggage limits. The practical impact for most Python web deployments is limited. The package must be installed separately, and the Jaeger propagator is not enabled by the default OpenTelemetry Python configuration. Common Python web servers also constrain request headers before they reach the propagator: - Gunicorn allows a maximum of 100 request-header fields and 8,190 bytes per field by default. - Uvicorn’s h11…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-f5m9-jfrj-jjj7

  2. Revision 1 · created ·

    Published from ghsa record GHSA-f5m9-jfrj-jjj7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116694

Advisory: OpenTelemetry Python: Unbounded memory allocation in Jaeger baggage propagation
IDs: CVE-2026-116694, GHSA-f5m9-jfrj-jjj7
Record: https://patchnext.com/advisories/cve-2026-116694 (revision 2, source checked 28 Oct 2026, 06:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: opentelemetry-propagator-jaeger 1.45.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI opentelemetry-propagator-jaeger: affected < 1.45.0; fixed in 1.45.0

## Suggested inspection (read-only)
- `python -m pip show opentelemetry-propagator-jaeger`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on opentelemetry-propagator-jaeger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f5m9-jfrj-jjj7 (GitHub-reviewed advisory GHSA-f5m9-jfrj-jjj7 lists affected ranges: PyPI opentelemetry-propagator-jaeger >=0 <=1.44.0)
- Verified: https://osv.dev/vulnerability/GHSA-f5m9-jfrj-jjj7 (OSV record GHSA-f5m9-jfrj-jjj7 lists affected ranges: PyPI opentelemetry-propagator-jaeger >=0 <1.45.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…