Skip to content

← Actionable
High, CVSS 8.7amended

dd-trace: ReDOS in URL query string obfuscation

CVE-2026-116693GHSA-x94g-w73q-hpcw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dd-trace 6.20.1, 5.131.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm dd-trace

    Affected
    >= 2.0.0, < 5.131.1>= 6.0.0, < 6.20.1
    Fixed in
    5.131.1, 6.20.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-116693: 0.45% estimated exploitation activity in the next 30 days; percentile 39.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A regular expression used to obfuscate URL query strings can consume excessive CPU when processing certain attacker-controlled input. This can stall request processing and cause denial of service in applications using affected HTTP tracing integrations.

Details The default query-string obfuscation pattern can exhibit excessive backtracking. The pattern is applied synchronously when recording HTTP URL metadata, allowing query-string processing to occupy application resources for an extended period. As a workaround, set DD_TRACE_OBFUSCATION_QUERY_STRING_REGEXP to the fixed regex below, then restart the application. ```…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-x94g-w73q-hpcw

  2. Revision 1 · created ·

    Published from ghsa record GHSA-x94g-w73q-hpcw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116693

Advisory: dd-trace: ReDOS in URL query string obfuscation
IDs: CVE-2026-116693, GHSA-x94g-w73q-hpcw
Record: https://patchnext.com/advisories/cve-2026-116693 (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dd-trace 6.20.1, 5.131.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dd-trace: affected >= 2.0.0, < 5.131.1; >= 6.0.0, < 6.20.1; fixed in 5.131.1, 6.20.1

## Suggested inspection (read-only)
- `npm ls dd-trace --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dd-trace.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x94g-w73q-hpcw (GitHub-reviewed advisory GHSA-x94g-w73q-hpcw lists affected ranges: npm dd-trace >=2.0.0 =6.0.0 <6.20.1)
- Verified: https://osv.dev/vulnerability/GHSA-x94g-w73q-hpcw (OSV record GHSA-x94g-w73q-hpcw lists affected ranges: npm dd-trace >=2.0.0 =6.0.0 <6.20.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…