MLflow vulnerable to remote code execution on unauthenticated servers via third-party scorer deserialization importing caller-placed artifact modules
CVE-2026-116692GHSA-26p8-2jq9-3vq9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 3.17.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mlflow
- Affected
- >= 3.12.0rc0, < 3.17.0
- Fixed in
- 3.17.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-26p8-2jq9-3vq9 lists affected ranges: PyPI mlflow >=3.12.0rc0 <3.17.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-26p8-2jq9-3vq9 lists affected ranges: PyPI mlflow >=3.12.0rc0 <3.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-116692: 0.70% estimated exploitation activity in the next 30 days; percentile 53.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary MLflow 3.12.0 introduced registration and deserialization support for third-party scorers in OSS MLflow. During scorer deserialization, the server accepts a request-controlled Python module path beneath one of four allowed package prefixes, imports that module, obtains a request-controlled class, and instantiates it synchronously. An HTTP caller can combine this behavior with MLflow's built-in experiment, run, and artifact-upload endpoints: 1. Create an experiment whose local artifact location points to a writable allowed scorer package. 2. Create a run, causing MLflow to allocate ` / /artifacts/`. 3. Upload a Python module into that run artifact directory. 4. Submit a serialized third-party scorer whose module path resolves to the uploaded file. 5. Trigger server-side import and class construction through `/ajax-api/3.0/mlflow/scorer/invoke`. On the default no-auth server using the official MLflow v3.14.0 image, this produces unauthenticated arbitrary Python code…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-26p8-2jq9-3vq9
- Revision 1 · created ·
Published from ghsa record GHSA-26p8-2jq9-3vq9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-116692 Advisory: MLflow vulnerable to remote code execution on unauthenticated servers via third-party scorer deserialization importing caller-placed artifact modules IDs: CVE-2026-116692, GHSA-26p8-2jq9-3vq9 Record: https://patchnext.com/advisories/cve-2026-116692 (revision 2, source checked 28 Oct 2026, 06:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mlflow 3.17.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mlflow: affected >= 3.12.0rc0, < 3.17.0; fixed in 3.17.0 ## Suggested inspection (read-only) - `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mlflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-26p8-2jq9-3vq9 (OSV record GHSA-26p8-2jq9-3vq9 lists affected ranges: PyPI mlflow >=3.12.0rc0 <3.17.0 (fixed)) - Verified: https://github.com/advisories/GHSA-26p8-2jq9-3vq9 (GitHub-reviewed advisory GHSA-26p8-2jq9-3vq9 lists affected ranges: PyPI mlflow >=3.12.0rc0 <3.17.0) Commands are suggestions: review each one before running it.
Loading voting…