Skip to content

← Actionable
High, CVSS 8.2amended

follow-redirects: Cross-realm sensitiveHeaders arrays are discarded and custom credentials can follow redirects

CVE-2026-116689GHSA-mrwp-f3q8-3g9p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (follow-redirects 1.16.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-116689: 0.27% estimated exploitation activity in the next 30 days; percentile 18.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary follow-redirects 1.16.0 and 1.16.1 validate the documented sensitiveHeaders option with instanceof Array. An array created in another JavaScript realm is silently replaced with an empty list, so a caller-declared custom credential header can be forwarded to an attacker-controlled cross-origin redirect destination.

Details Affected versions The sensitiveHeaders option was introduced in 1.16.0. Published 1.16.0 and 1.16.1 both reproduced, giving a tested affected range of 1.16.0 through 1.16.1. The source checkout was pinned at revision 46301256333c90b7faac7aa126effe72ec16d16e; the exact npm 1.16.1 artifact reproduced independently. Root cause index.js resets options.sensitiveHeaders when its local isArray() helper returns false. That helper uses value instanceof Array, which depends on realm identity. The same file already uses Array.isArray(options.headers), which correctly recognizes arrays across realms. Suggested remediation Use Array.isArray(value) for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-mrwp-f3q8-3g9p

  2. Revision 1 · created ·

    Published from ghsa record GHSA-mrwp-f3q8-3g9p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116689

Advisory: follow-redirects: Cross-realm sensitiveHeaders arrays are discarded and custom credentials can follow redirects
IDs: CVE-2026-116689, GHSA-mrwp-f3q8-3g9p
Record: https://patchnext.com/advisories/cve-2026-116689 (revision 2, source checked 31 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: follow-redirects 1.16.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm follow-redirects: affected >= 1.16.0, < 1.16.2; fixed in 1.16.2

## Suggested inspection (read-only)
- `npm ls follow-redirects --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on follow-redirects.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mrwp-f3q8-3g9p (GitHub-reviewed advisory GHSA-mrwp-f3q8-3g9p lists affected ranges: npm follow-redirects >=1.16.0 <=1.16.1)
- Verified: https://osv.dev/vulnerability/GHSA-mrwp-f3q8-3g9p (OSV record GHSA-mrwp-f3q8-3g9p lists affected ranges: npm follow-redirects >=1.16.0 <1.16.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…