Skip to content

← Actionable
Medium, CVSS 6.8amended

Model Context Protocol Python SDK: Server bearer-token authentication accepts tokens issued for a different resource server

CVE-2026-116684GHSA-w4fh-qvv9-3v23

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp 2.2.0, 1.30.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mcp

    Affected
    >= 2.0.0, < 2.2.0>= 1.10.0, < 1.30.0
    Fixed in
    2.2.0, 1.30.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-116684: 0.36% estimated exploitation activity in the next 30 days; percentile 30.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions, the SDK's server-side bearer authentication had no way to check that a token was issued for your server (its audience). Where one authorization server issues tokens for several services, a valid token for another service was also accepted by your MCP server.

Am I affected? Yes, if your HTTP server uses the SDK's bearer authentication (`auth=AuthSettings(...)` with `token_verifier=`), its authorization server also issues tokens for other services, and your `TokenVerifier` does not check the token's audience (`aud`) itself. Affected versions: - `mcp` 1.10.0 through 1.29.1 - `mcp` 2.0.0 through 2.1.1

Fix Upgrade to: - 1.x: `mcp` 1.30.0 or later - 2.x: `mcp` 2.2.0 or later Upgrading alone changes nothing. The patched versions add a `validate_token_resource` setting that is off unless you set it. To turn the check on, make both of these changes together: 1. Set `validate_token_resource=True` in `AuthSettings`, with `resource_server_url` set to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-w4fh-qvv9-3v23

  2. Revision 1 · created ·

    Published from ghsa record GHSA-w4fh-qvv9-3v23

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116684

Advisory: Model Context Protocol Python SDK: Server bearer-token authentication accepts tokens issued for a different resource server
IDs: CVE-2026-116684, GHSA-w4fh-qvv9-3v23
Record: https://patchnext.com/advisories/cve-2026-116684 (revision 2, source checked 28 Oct 2026, 06:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp 2.2.0, 1.30.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp: affected >= 2.0.0, < 2.2.0; >= 1.10.0, < 1.30.0; fixed in 2.2.0, 1.30.0

## Suggested inspection (read-only)
- `python -m pip show mcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w4fh-qvv9-3v23 (OSV record GHSA-w4fh-qvv9-3v23 lists affected ranges: PyPI mcp >=2.0.0 =1.10.0 <1.30.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w4fh-qvv9-3v23 (GitHub-reviewed advisory GHSA-w4fh-qvv9-3v23 lists affected ranges: PyPI mcp >=2.0.0 =1.10.0 <1.30.0)

Commands are suggestions: review each one before running it.

Loading voting…