OpenWISP Controller CA CRL REST API does not scope requests to managed organizations
CVE-2026-116677GHSA-9gh4-xw24-9xh5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openwisp-controller 1.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI openwisp-controller
- Affected
- >= 1.0.0, < 1.3.2
- Fixed in
- 1.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9gh4-xw24-9xh5 lists affected ranges: PyPI openwisp-controller >=1.0.0 <1.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9gh4-xw24-9xh5 lists affected ranges: PyPI openwisp-controller >=1.0.0 <1.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-116677: 0.18% estimated exploitation activity in the next 30 days; percentile 6.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The authenticated REST API endpoint for downloading a CA Certificate Revocation List resolves the requested CA without applying the organization-scoped queryset used by the rest of the PKI API. An organization manager with CA view permission can request another organization's sequential CA ID and receive that CA's CRL. The endpoint is intended to be authenticated and organization-scoped, so it should use the same access-control path as `GET /api/v1/controller/ca/ /`.
Affected endpoint ```text GET /api/v1/controller/ca/ /crl ``` `CrlDownloadView` inherits `ProtectedAPIMixin`, which requires an authenticated organization manager with the relevant model permission. However, `retrieve()` resolves the CA with `get_object_or_404(Ca, pk=kwargs["pk"])`. This bypasses `FilterByOrganizationManaged` and does not perform an object-level permission check. Consequently, a manager of organization A can enumerate CA integer IDs and retrieve the CRL for a CA belonging to organization B.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-9gh4-xw24-9xh5
- Revision 1 · created ·
Published from ghsa record GHSA-9gh4-xw24-9xh5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-116677 Advisory: OpenWISP Controller CA CRL REST API does not scope requests to managed organizations IDs: CVE-2026-116677, GHSA-9gh4-xw24-9xh5 Record: https://patchnext.com/advisories/cve-2026-116677 (revision 2, source checked 31 Oct 2026, 06:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openwisp-controller 1.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI openwisp-controller: affected >= 1.0.0, < 1.3.2; fixed in 1.3.2 ## Suggested inspection (read-only) - `python -m pip show openwisp-controller`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openwisp-controller. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9gh4-xw24-9xh5 (GitHub-reviewed advisory GHSA-9gh4-xw24-9xh5 lists affected ranges: PyPI openwisp-controller >=1.0.0 <1.3.2) - Verified: https://osv.dev/vulnerability/GHSA-9gh4-xw24-9xh5 (OSV record GHSA-9gh4-xw24-9xh5 lists affected ranges: PyPI openwisp-controller >=1.0.0 <1.3.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…