TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin data-mce-object serialization
CVE-2026-116675GHSA-mf2p-h6hf-fcwm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 8.9.3, 7.9.4; tinymce/tinymce 8.9.3, 7.9.4; tinymce 8.9.3, 7.9.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet tinymce
- Affected
- >= 8.5.1, < 8.9.3>= 7.9.3, < 7.9.4
- Fixed in
- 8.9.3, 7.9.4
Packagist tinymce/tinymce
- Affected
- >= 8.5.1, < 8.9.3>= 7.9.3, < 7.9.4
- Fixed in
- 8.9.3, 7.9.4
npm tinymce
- Affected
- >= 8.5.1, < 8.9.3>= 7.9.3, < 7.9.4
- Fixed in
- 8.9.3, 7.9.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mf2p-h6hf-fcwm lists affected ranges: npm tinymce >=8.5.1 =7.9.3 =8.5.1 =7.9.3 =8.5.1 =7.9.3 <=7.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mf2p-h6hf-fcwm lists affected ranges: npm tinymce >=8.5.1 =7.9.3 =8.5.1 =7.9.3 =8.5.1 =7.9.3 <7.9.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-116675: 0.35% estimated exploitation activity in the next 30 days; percentile 28.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.
Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.
Workarounds No official workaround available.
Fix To avoid this vulnerability: Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher.
Acknowledgements Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-mf2p-h6hf-fcwm
- Revision 1 · created ·
Published from ghsa record GHSA-mf2p-h6hf-fcwm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-116675 Advisory: TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization IDs: CVE-2026-116675, GHSA-mf2p-h6hf-fcwm Record: https://patchnext.com/advisories/cve-2026-116675 (revision 2, source checked 28 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tinymce 8.9.3, 7.9.4; tinymce/tinymce 8.9.3, 7.9.4; tinymce 8.9.3, 7.9.4. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet tinymce: affected >= 8.5.1, < 8.9.3; >= 7.9.3, < 7.9.4; fixed in 8.9.3, 7.9.4 - Packagist tinymce/tinymce: affected >= 8.5.1, < 8.9.3; >= 7.9.3, < 7.9.4; fixed in 8.9.3, 7.9.4 - npm tinymce: affected >= 8.5.1, < 8.9.3; >= 7.9.3, < 7.9.4; fixed in 8.9.3, 7.9.4 ## Suggested inspection (read-only) - NuGet tinymce: check the installed version with your package manager. - Packagist tinymce/tinymce: check the installed version with your package manager. - `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tinymce, tinymce/tinymce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mf2p-h6hf-fcwm (GitHub-reviewed advisory GHSA-mf2p-h6hf-fcwm lists affected ranges: npm tinymce >=8.5.1 =7.9.3 =8.5.1 =7.9.3 =8.5.1 =7.9.3 <=7.9.3) - Verified: https://osv.dev/vulnerability/GHSA-mf2p-h6hf-fcwm (OSV record GHSA-mf2p-h6hf-fcwm lists affected ranges: npm tinymce >=8.5.1 =7.9.3 =8.5.1 =7.9.3 =8.5.1 =7.9.3 <7.9.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…