Skip to content

← Actionable
Low, CVSS 3.3amended

systeminformation has path traversal in Linux networkStats() that allows symlink-based file disclosure outside /sys/class/net

CVE-2026-116673GHSA-4vjg-vx72-qq4g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (systeminformation 5.33.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-116673: 0.13% estimated exploitation activity in the next 30 days; percentile 2.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary On Linux, `systeminformation@5.33.13` builds `/sys/class/net/ ` paths from the caller-supplied `networkStats(iface)` value without checking that the resolved path stays inside `/sys/class/net`. A caller who can create a symlink fixture and control the value passed to this API can make the function return the first line of a file readable by the Node process.

Details The strict string sanitizer removes shell metacharacters but retains `/` and `.`. The Linux implementation uses this value in an `fs.existsSync('/sys/class/net/' + iface)` check and then in seven `cat` paths for interface statistics. Both operations follow `..` path components and symlinks. The code does not validate the value as an interface name or enforce resolved-path containment. The proof of concept below creates the expected statistics files in a directory writable by the unprivileged `nobody` user. Its `operstate` symlink points to a synthetic mode-0600 file under `/root`. The package call runs as…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-4vjg-vx72-qq4g

  2. Revision 1 · created ·

    Published from ghsa record GHSA-4vjg-vx72-qq4g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116673

Advisory: systeminformation has path traversal in Linux networkStats() that allows symlink-based file disclosure outside /sys/class/net
IDs: CVE-2026-116673, GHSA-4vjg-vx72-qq4g
Record: https://patchnext.com/advisories/cve-2026-116673 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: systeminformation 5.33.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm systeminformation: affected < 5.33.14; fixed in 5.33.14

## Suggested inspection (read-only)
- `npm ls systeminformation --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on systeminformation.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4vjg-vx72-qq4g (GitHub-reviewed advisory GHSA-4vjg-vx72-qq4g lists affected ranges: npm systeminformation >=0 <5.33.14)
- Verified: https://osv.dev/vulnerability/GHSA-4vjg-vx72-qq4g (OSV record GHSA-4vjg-vx72-qq4g lists affected ranges: npm systeminformation >=0 <5.33.14 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…