Datadog dd-trace-py: IAST instrumentation can lead to application DOS
CVE-2026-116589GHSA-p3m5-h5v9-vqj6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ddtrace 4.15.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ddtrace
- Affected
- >= 3.13.0, < 4.15.5
- Fixed in
- 4.15.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p3m5-h5v9-vqj6 lists affected ranges: PyPI ddtrace >=3.13.0 <4.15.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p3m5-h5v9-vqj6 lists affected ranges: PyPI ddtrace >=3.13.0 <4.15.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-116589: 0.33% estimated exploitation activity in the next 30 days; percentile 25.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A flaw in dd-trace-py’s IAST instrumentation can cause the Python application process to terminate unexpectedly when processing certain attacker-controlled input. Only applications with IAST enabled are affected. IAST is disabled by default.
Details The affected IAST string-processing instrumentation does not properly handle certain internal errors, allowing an error to terminate the application process. Exploitation requires IAST to be enabled and application code to perform an affected string-processing operation on attacker-controlled input. If you are unable to upgrade to a patched version of dd-trace-py, you can mitigate this issue by either disabling IAST (setting DD_IAST_ENABLED=false) or by replacing replace % string interpolations with str.format or f-strings for user inputs in your monitored application.
Proof of concept Detailed triggering inputs and reproduction steps are omitted from this advisory. The linked fix (#20786) includes regression coverage…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-p3m5-h5v9-vqj6
- Revision 1 · created ·
Published from ghsa record GHSA-p3m5-h5v9-vqj6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-116589 Advisory: Datadog dd-trace-py: IAST instrumentation can lead to application DOS IDs: CVE-2026-116589, GHSA-p3m5-h5v9-vqj6 Record: https://patchnext.com/advisories/cve-2026-116589 (revision 2, source checked 28 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ddtrace 4.15.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ddtrace: affected >= 3.13.0, < 4.15.5; fixed in 4.15.5 ## Suggested inspection (read-only) - `python -m pip show ddtrace`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ddtrace. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p3m5-h5v9-vqj6 (OSV record GHSA-p3m5-h5v9-vqj6 lists affected ranges: PyPI ddtrace >=3.13.0 <4.15.5 (fixed)) - Verified: https://github.com/advisories/GHSA-p3m5-h5v9-vqj6 (GitHub-reviewed advisory GHSA-p3m5-h5v9-vqj6 lists affected ranges: PyPI ddtrace >=3.13.0 <4.15.5) Commands are suggestions: review each one before running it.
Loading voting…