Skip to content

← Actionable
High, CVSS 7.5amended

Seroval fromJSON/fromCrossJSON denial of service via unvalidated array node length

CVE-2026-116584GHSA-wp97-x4hv-qvhp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (seroval 1.6.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm seroval

    Affected
    >= 1.4.1, < 1.6.8
    Fixed in
    1.6.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-116584: 0.36% estimated exploitation activity in the next 30 days; percentile 30.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `fromJSON` and `fromCrossJSON` did not check that an array node's element list is an array. A small crafted payload could set the length the decoder used. That length controlled how much memory was allocated and how many times the decoder looped, and it did not depend on the size of the payload.

Impact A service that passes untrusted input to `fromJSON` or `fromCrossJSON` can be made unavailable by an unauthenticated request. - A small payload can allocate enough memory to end the process. - A small payload can block the thread for seconds, or without end. This affects any framework that decodes request bodies with these functions before its own validation runs. This issue is a bypass of the fix for GHSA-66fc-rw6m-c2q6 in 1.4.1.

Patches Fixed in `seroval@1.6.8`. The deserializer now rejects any node whose element list is not an array, and throws `SerovalMalformedNodeError`.

Workarounds None. Upgrade to 1.6.8.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-wp97-x4hv-qvhp

  2. Revision 1 · created ·

    Published from ghsa record GHSA-wp97-x4hv-qvhp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116584

Advisory: Seroval `fromJSON`/`fromCrossJSON` denial of service via unvalidated array node length
IDs: CVE-2026-116584, GHSA-wp97-x4hv-qvhp
Record: https://patchnext.com/advisories/cve-2026-116584 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: seroval 1.6.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm seroval: affected >= 1.4.1, < 1.6.8; fixed in 1.6.8

## Suggested inspection (read-only)
- `npm ls seroval --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on seroval.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wp97-x4hv-qvhp (OSV record GHSA-wp97-x4hv-qvhp lists affected ranges: npm seroval >=1.4.1 <1.6.8 (fixed))
- Verified: https://github.com/advisories/GHSA-wp97-x4hv-qvhp (GitHub-reviewed advisory GHSA-wp97-x4hv-qvhp lists affected ranges: npm seroval >=1.4.1 <=1.6.7)

Commands are suggestions: review each one before running it.

Loading voting…