Skip to content

← Actionable
Medium, CVSS 4.7amended

Seroval: Script injection through RegExp sources in serialized output

CVE-2026-116582GHSA-9wx9-5pv9-3349

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (seroval 1.6.10, 1.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm seroval

    Affected
    >= 1.5.5, < 1.6.10< 1.0.0
    Fixed in
    1.6.10, 1.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-116582: 0.19% estimated exploitation activity in the next 30 days; percentile 8.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary seroval writes a `RegExp` as a regular expression literal. In affected versions, the ` ` element that the serialized output is placed in, and run script in the page.

Details seroval escapes ` ` element. `RegExp` sources did not get the same escaping: - Versions before 1.0.0 wrote the source as is. - Version 1.5.5 stopped escaping ` ` element, as server rendering usually does. In that case an attacker can run script in the page of any user who receives that output.

Patches Fixed in 1.6.10. A `RegExp` whose source contains `<` is now written with the `RegExp` constructor and an escaped string source. Named groups and lookbehinds keep working.

Workarounds If you cannot upgrade: - Do not serialize a `RegExp` built from untrusted pattern syntax. Send its source and flags as strings, and build the `RegExp` on the client. - Or reject patterns that contain `<` before they reach the serializer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-9wx9-5pv9-3349

  2. Revision 1 · created ·

    Published from ghsa record GHSA-9wx9-5pv9-3349

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116582

Advisory: Seroval: Script injection through RegExp sources in serialized output
IDs: CVE-2026-116582, GHSA-9wx9-5pv9-3349
Record: https://patchnext.com/advisories/cve-2026-116582 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: seroval 1.6.10, 1.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm seroval: affected >= 1.5.5, < 1.6.10; < 1.0.0; fixed in 1.6.10, 1.0.0

## Suggested inspection (read-only)
- `npm ls seroval --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on seroval.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9wx9-5pv9-3349 (OSV record GHSA-9wx9-5pv9-3349 lists affected ranges: npm seroval >=1.5.5 =0 <1.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9wx9-5pv9-3349 (GitHub-reviewed advisory GHSA-9wx9-5pv9-3349 lists affected ranges: npm seroval >=1.5.5 =0 <1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…