rclone from 1.37 before 1.74.2 SSRF via --rc-serve scheme-relative remote roots
CVE-2026-116192GHSA-xqmq-v4wj-rw5m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rclone 1.74.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami rclone
- Affected
- >= 1.37.0, < 1.74.2
- Fixed in
- 1.74.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-rclone-2026-116192 lists affected ranges: Bitnami rclone >=1.37.0 <1.74.2 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-116192: 0.22% estimated exploitation activity in the next 30 days; percentile 13.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
rclone from 1.37 before 1.74.2 contains a server-side request forgery vulnerability that allows unauthenticated attackers to redirect http and netstorage backend requests by supplying a double-slash root on an existing named remote via --rc-serve. Attackers can make HEAD/GET requests to attacker-chosen hosts to read responses, capture configured custom headers, or obtain valid NetStorage request signatures.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record BIT-rclone-2026-116192
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-116192 Advisory: rclone from 1.37 before 1.74.2 SSRF via --rc-serve scheme-relative remote roots IDs: CVE-2026-116192, GHSA-xqmq-v4wj-rw5m Record: https://patchnext.com/advisories/cve-2026-116192 (revision 1, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rclone 1.74.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami rclone: affected >= 1.37.0, < 1.74.2; fixed in 1.74.2 ## Suggested inspection (read-only) - Bitnami rclone: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rclone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/BIT-rclone-2026-116192 (OSV record BIT-rclone-2026-116192 lists affected ranges: Bitnami rclone >=1.37.0 <1.74.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…