Skip to content

← Actionable
Medium, CVSS 6.5amended

Backstage catalog rules can be bypassed for URL locations using encoded path segments

CVE-2026-115923GHSA-w658-mh9p-ww8f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-catalog-backend 4.0.2, 3.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-115923: 0.32% estimated exploitation activity in the next 30 days; percentile 24.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `@backstage/plugin-catalog-backend` matches URL-type locations against `catalog.rules` location patterns using the raw URL string submitted by the user, while URL readers resolve that same string in canonical form when fetching the location's content. A URL can therefore be crafted so that it appears to belong to a trusted location scope during rule evaluation, but is fetched from a different scope.

Details When a deployment restricts catalog kinds to trusted URL prefixes using `catalog.rules` location patterns, `DefaultCatalogRulesEnforcer` applies glob matching directly to the raw `location.target` string. The URL readers used for ingestion resolve the same target in canonical form, including normalizing percent-encoded dot segments. A registered location such as `https:// /trusted/%2e%2e/attacker/repo/blob/main/catalog-info.yaml` matches a `https:// /trusted/**` pattern as a raw string, but resolves to and is fetched from `https:// /attacker/repo/...` when its…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-w658-mh9p-ww8f

  2. Revision 1 · created ·

    Published from ghsa record GHSA-w658-mh9p-ww8f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115923

Advisory: Backstage catalog rules can be bypassed for URL locations using encoded path segments
IDs: CVE-2026-115923, GHSA-w658-mh9p-ww8f
Record: https://patchnext.com/advisories/cve-2026-115923 (revision 2, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-catalog-backend 4.0.2, 3.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-catalog-backend: affected < 3.9.2; >= 4.0.0, < 4.0.2; fixed in 3.9.2, 4.0.2

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-catalog-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-catalog-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w658-mh9p-ww8f (GitHub-reviewed advisory GHSA-w658-mh9p-ww8f lists affected ranges: npm @backstage/plugin-catalog-backend >=0 =4.0.0 <4.0.2)
- Verified: https://osv.dev/vulnerability/GHSA-w658-mh9p-ww8f (OSV record GHSA-w658-mh9p-ww8f lists affected ranges: npm @backstage/plugin-catalog-backend >=0 =4.0.0 <4.0.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…