ONNX: Denial of service via unchecked expansion of packed sub-byte tensors in ONNX Python APIs
CVE-2026-115922GHSA-q69g-f4f5-v8m7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (onnx 1.22.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI onnx
- Affected
- < 1.22.0
- Fixed in
- 1.22.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q69g-f4f5-v8m7 lists affected ranges: PyPI onnx >=0 <=1.21.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q69g-f4f5-v8m7 lists affected ranges: PyPI onnx >=0 <1.22.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-115922: 0.13% estimated exploitation activity in the next 30 days; percentile 2.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary ONNX's Python tensor-materialization helpers could allocate memory according to attacker-controlled tensor dimensions without verifying that a packed sub-byte payload contained the declared number of elements. A very small model could therefore cause a disproportionately large allocation when an application called `onnx.numpy_helper.to_array()` or constructed `onnx.reference.ReferenceEvaluator` with the model. The issue affected `UINT2`, `INT2`, `UINT4`, `INT4`, and `FLOAT4E2M1` tensors stored in either `raw_data` or packed `int32_data`.
Technical details The vulnerable `_unpack_2bit()` and `_unpack_4bit()` paths first allocated a small array based on the available packed bytes, then resized it to the shape declared in `TensorProto.dims`. They did not first confirm that the payload encoded enough logical elements for that shape. For example, the reporter demonstrated a 66-byte model containing one packed byte and a declared dimension of 700,000,000. The model passed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-q69g-f4f5-v8m7
- Revision 1 · created ·
Published from ghsa record GHSA-q69g-f4f5-v8m7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-115922 Advisory: ONNX: Denial of service via unchecked expansion of packed sub-byte tensors in ONNX Python APIs IDs: CVE-2026-115922, GHSA-q69g-f4f5-v8m7 Record: https://patchnext.com/advisories/cve-2026-115922 (revision 2, source checked 29 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: onnx 1.22.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI onnx: affected < 1.22.0; fixed in 1.22.0 ## Suggested inspection (read-only) - `python -m pip show onnx`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on onnx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q69g-f4f5-v8m7 (GitHub-reviewed advisory GHSA-q69g-f4f5-v8m7 lists affected ranges: PyPI onnx >=0 <=1.21.0) - Verified: https://osv.dev/vulnerability/GHSA-q69g-f4f5-v8m7 (OSV record GHSA-q69g-f4f5-v8m7 lists affected ranges: PyPI onnx >=0 <1.22.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…