vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs
CVE-2026-115918GHSA-x567-49g5-p4cf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.32.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.16.0, < 0.32.0
- Fixed in
- 0.32.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x567-49g5-p4cf lists affected ranges: PyPI vllm >=0.16.0 <0.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x567-49g5-p4cf lists affected ranges: PyPI vllm >=0.16.0 <0.32.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-4349 lists affected ranges: PyPI vllm >=0.16.0 <0.32.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-115918: 0.35% estimated exploitation activity in the next 30 days; percentile 28.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary vLLM's `/v1/responses` endpoint accepts request-level `chat_template_kwargs`, but does not apply the `--trust-request-chat-template` gate that protects Chat Completions, render, tokenize, and pooling paths. When the server is run with the documented default `trust_request_chat_template=False` and no explicit `--chat-template`, a Responses request can pass: ```json {"chat_template_kwargs": {"chat_template": " "}} ``` That key is preserved by `ChatParams.get_apply_chat_template_kwargs()` and then bound as the `chat_template` parameter to the shared HF renderer. Prior vLLM advisories establish that request-controlled Jinja chat templates can cause CPU/memory exhaustion. This report covers the current-head Responses sibling path missed by the earlier fixes.
Technical Details The shared OpenAI frontend has a validation helper that rejects request-supplied chat templates unless the trust flag is enabled. It explicitly checks both top-level `chat_template` and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record PYSEC-2026-4349
- Revision 3 · amended ·
Amended from osv record GHSA-x567-49g5-p4cf
- Revision 2 · amended ·
Amended from osv record GHSA-x567-49g5-p4cf
- Revision 1 · created ·
Published from ghsa record GHSA-x567-49g5-p4cf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-115918 Advisory: vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs IDs: CVE-2026-115918, GHSA-x567-49g5-p4cf Record: https://patchnext.com/advisories/cve-2026-115918 (revision 4, source checked 30 Oct 2026, 06:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.32.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.16.0, < 0.32.0; fixed in 0.32.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x567-49g5-p4cf (GitHub-reviewed advisory GHSA-x567-49g5-p4cf lists affected ranges: PyPI vllm >=0.16.0 <0.32.0) - Verified: https://osv.dev/vulnerability/GHSA-x567-49g5-p4cf (OSV record GHSA-x567-49g5-p4cf lists affected ranges: PyPI vllm >=0.16.0 <0.32.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-4349 (OSV record PYSEC-2026-4349 lists affected ranges: PyPI vllm >=0.16.0 <0.32.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…