Skip to content

← Actionable
Low, CVSS 3.4amended

vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server

CVE-2026-115917GHSA-vvpg-rrww-wpmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.32.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.32.0
    Fixed in
    0.32.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2026-115917: 0.24% estimated exploitation activity in the next 30 days; percentile 15.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The OpenAI-compatible server registers Starlette `CORSMiddleware` with `allowed_origins` defaulting to `["*"]`, and performs no authentication unless `--api-key` (or `VLLM_API_KEY`) is configured. A web page on any origin can send requests to a vLLM server that the victim's browser can reach (for example `localhost` or an internal/VPN address) and read the responses. The default `allow_credentials=False` blocks cookie-bearing cross-origin requests; because vLLM authenticates with a bearer header rather than cookies, the wildcard still permits untokenized access to an unauthenticated server and read access when the caller already holds a token.

Details Affected components - `vllm/entrypoints/launchers/cli_args.py` - `allowed_origins` default value. - `vllm/entrypoints/serve/middleware/register.py` - `CORSMiddleware` registration. - `vllm/entrypoints/serve/middleware/authenticate.py` - auth middleware and its guarded path prefixes. Root cause…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record PYSEC-2026-4348

  2. Revision 3 · amended ·

    Amended from osv record GHSA-vvpg-rrww-wpmh

  3. Revision 2 · amended ·

    Amended from osv record GHSA-vvpg-rrww-wpmh

  4. Revision 1 · created ·

    Published from ghsa record GHSA-vvpg-rrww-wpmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115917

Advisory: vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server
IDs: CVE-2026-115917, GHSA-vvpg-rrww-wpmh
Record: https://patchnext.com/advisories/cve-2026-115917 (revision 4, source checked 30 Oct 2026, 06:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.32.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.32.0; fixed in 0.32.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vvpg-rrww-wpmh (OSV record GHSA-vvpg-rrww-wpmh lists affected ranges: PyPI vllm >=0 <0.32.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vvpg-rrww-wpmh (GitHub-reviewed advisory GHSA-vvpg-rrww-wpmh lists affected ranges: PyPI vllm >=0 <0.32.0)
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4348 (OSV record PYSEC-2026-4348 lists affected ranges: PyPI vllm >=0 <0.32.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…