Skip to content

← Actionable
Medium, CVSS 6.5amended

vLLM: Out-of-vocabulary prompt token id passes input validation and triggers a CUDA device-side assert (engine crash / DoS)

CVE-2026-115916GHSA-q97c-p368-75c4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.32.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.32.0
    Fixed in
    0.32.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-115916: 0.31% estimated exploitation activity in the next 30 days; percentile 24.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

For a model whose vocabulary size is an exact multiple of the embedding padding size (64) — e.g. any Llama-2-family model, vocab 32000 — a single request carrying a pre-tokenized prompt with token id equal to the vocab size (32000) passes vLLM's input-id validation but is one past the last embedding row. At tensor-parallel size 1 the embedding lookup does not mask indices, so the id reaches `F.embedding` out of range and raises a CUDA device-side assert, which poisons the engine's CUDA context and takes the engine down. Any client that can send pre-tokenized input (`/v1/completions` with `prompt` as token ids, `/tokenize`-fed flows, or the `kv_transfer_params["prompt_token_ids"]` reuse path) can trigger it.

Root cause `vllm/v1/engine/input_processor.py` accepts a token id when `id 1 masks via `get_masked_input_and_mask`, so the id is clamped, not an OOB — likely wrong output rather than a crash. - Models whose vocab is a multiple of 64 with `tokenizer.vocab_size` one past the max…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record PYSEC-2026-4347

  2. Revision 3 · amended ·

    Amended from osv record GHSA-q97c-p368-75c4

  3. Revision 2 · amended ·

    Amended from osv record GHSA-q97c-p368-75c4

  4. Revision 1 · created ·

    Published from ghsa record GHSA-q97c-p368-75c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115916

Advisory: vLLM: Out-of-vocabulary prompt token id passes input validation and triggers a CUDA device-side assert (engine crash / DoS)
IDs: CVE-2026-115916, GHSA-q97c-p368-75c4
Record: https://patchnext.com/advisories/cve-2026-115916 (revision 4, source checked 30 Oct 2026, 06:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.32.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.32.0; fixed in 0.32.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q97c-p368-75c4 (OSV record GHSA-q97c-p368-75c4 lists affected ranges: PyPI vllm >=0 <0.32.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q97c-p368-75c4 (GitHub-reviewed advisory GHSA-q97c-p368-75c4 lists affected ranges: PyPI vllm >=0 <0.32.0)
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4347 (OSV record PYSEC-2026-4347 lists affected ranges: PyPI vllm >=0 <0.32.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…