Skip to content

← Actionable
High, CVSS 8.1amended

vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

CVE-2026-115915GHSA-h3rc-j82p-2c3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.32.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.32.0
    Fixed in
    0.32.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-115915: 0.66% estimated exploitation activity in the next 30 days; percentile 51.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In vLLM 0.30.0, `ImageMediaIO` passes attacker-controlled image bytes to Pillow's format autodetection without restricting the accepted formats; the request's MIME label does not constrain decoder selection. An EPS payload labeled `image/png` reached the host's Ghostscript executable. On a host with Ghostscript affected by CVE-2024-29510, this exposes the known Ghostscript sandbox escape through vLLM's image-loading path and can execute commands with the vLLM process's privileges. A bounded marker-command payload executed through the PyPI wheel's actual `ImageMediaIO.load_base64()` implementation using Debian Ghostscript 10.03.0. The loader-level execution is reproduced; the HTTP request path is source-traced but was not exercised end to end. This report concerns vLLM's untrusted-format dispatch and does not claim a new Ghostscript vulnerability. Exploitation requires an image-capable request path, a caller able to reach it under the deployment's authentication policy,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record PYSEC-2026-4346

  2. Revision 3 · amended ·

    Amended from osv record GHSA-h3rc-j82p-2c3h

  3. Revision 2 · amended ·

    Amended from osv record GHSA-h3rc-j82p-2c3h

  4. Revision 1 · created ·

    Published from ghsa record GHSA-h3rc-j82p-2c3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115915

Advisory: vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
IDs: CVE-2026-115915, GHSA-h3rc-j82p-2c3h
Record: https://patchnext.com/advisories/cve-2026-115915 (revision 4, source checked 30 Oct 2026, 06:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.32.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.32.0; fixed in 0.32.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h3rc-j82p-2c3h (OSV record GHSA-h3rc-j82p-2c3h lists affected ranges: PyPI vllm >=0 <0.32.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h3rc-j82p-2c3h (GitHub-reviewed advisory GHSA-h3rc-j82p-2c3h lists affected ranges: PyPI vllm >=0 <0.32.0)
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4346 (OSV record PYSEC-2026-4346 lists affected ranges: PyPI vllm >=0.30.0 <0.32.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…