Skip to content

← Actionable
High, CVSS 7.5amended

vLLM: Public multimodal SHM handle forgery reaches worker-side pickle.loads() with insecure serialization disabled

CVE-2026-115912GHSA-6757-hggm-hp2w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.32.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.32.0
    Fixed in
    0.32.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-115912: 0.51% estimated exploitation activity in the next 30 days; percentile 43.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected - Ecosystem / package: pip / `vllm` - Affected versions: vLLM MultiModalKwargsItem: assert mm_item is not None, f"Expected an address item for {mm_hash=}" if "address" in mm_item: address = cast(int, mm_item["address"].data) monotonic_id = cast(int, mm_item["monotonic_id"].data) return self._shm_cache.get(address, monotonic_id) return mm_item ``` The dereference lands in the SHM deserializer, which `pickle.loads()` any chunk tagged as `bytes` — so attacker bytes staged in the ring buffer are unpickled in the worker process: ```python

vllm/distributed/device_communicators/shm_object_storage.py Lines 375-400 def deserialize(self, data_view: memoryview) -> Any:

pickle.loads do not read past the end of a pickled object

within a large buffer, so we can skip storing the metadata size type_name, nbytes, len_arr = pickle.loads(data_view) serialized_data = data_view[-nbytes:] if type_name == torch.Tensor.name: obj = [] start_idx = 0 for length in len_arr:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record PYSEC-2026-4345

  2. Revision 3 · amended ·

    Amended from osv record GHSA-6757-hggm-hp2w

  3. Revision 2 · amended ·

    Amended from osv record GHSA-6757-hggm-hp2w

  4. Revision 1 · created ·

    Published from ghsa record GHSA-6757-hggm-hp2w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115912

Advisory: vLLM: Public multimodal SHM handle forgery reaches worker-side `pickle.loads()` with insecure serialization disabled
IDs: CVE-2026-115912, GHSA-6757-hggm-hp2w
Record: https://patchnext.com/advisories/cve-2026-115912 (revision 4, source checked 30 Oct 2026, 06:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.32.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.32.0; fixed in 0.32.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6757-hggm-hp2w (OSV record GHSA-6757-hggm-hp2w lists affected ranges: PyPI vllm >=0 <0.32.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6757-hggm-hp2w (GitHub-reviewed advisory GHSA-6757-hggm-hp2w lists affected ranges: PyPI vllm >=0 <0.32.0)
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4345 (OSV record PYSEC-2026-4345 lists affected ranges: PyPI vllm >=0 <0.32.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…