Skip to content

← Actionable
Medium, CVSS 6.5amended

vLLM: DoS via unbounded chat_template Jinja2 rendering exhausts the renderer thread pool

CVE-2026-115911GHSA-542m-9234-8gvf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.32.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.19.0, < 0.32.0
    Fixed in
    0.32.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-115911: 0.31% estimated exploitation activity in the next 30 days; percentile 24.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary vLLM renders chat templates by passing the resolved Jinja2 source to `tokenizer.apply_chat_template()`, which compiles and `.render()`s it in an `ImmutableSandboxedEnvironment`. The sandbox prevents code-execution escapes but imposes no wall-clock timeout, no output-size cap, and no nested-loop or binop limit. The render runs in a `ThreadPoolExecutor` whose `max_workers` defaults to 1, and CPython worker threads cannot be interrupted. An authenticated API client (or a malicious model repo loaded with `trust_remote_code=False`) can therefore submit a single short template and permanently wedge all chat-style endpoints (`/v1/chat/completions`, `/v1/responses`, `/tokenize`, `/pooling`-chat, `/invocations`-chat) for every tenant until the process is restarted. A string-multiplication variant instead OOM-kills the API-server process. Because of a separately-reported (GHSA-jmjw-q4x3-hmc2) gate omission on `/v1/responses`, the remote authenticated attacker vector…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record PYSEC-2026-4344

  2. Revision 3 · amended ·

    Amended from osv record GHSA-542m-9234-8gvf

  3. Revision 2 · amended ·

    Amended from osv record GHSA-542m-9234-8gvf

  4. Revision 1 · created ·

    Published from ghsa record GHSA-542m-9234-8gvf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115911

Advisory: vLLM: DoS via unbounded chat_template Jinja2 rendering exhausts the renderer thread pool
IDs: CVE-2026-115911, GHSA-542m-9234-8gvf
Record: https://patchnext.com/advisories/cve-2026-115911 (revision 4, source checked 30 Oct 2026, 06:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.32.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.19.0, < 0.32.0; fixed in 0.32.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-542m-9234-8gvf (GitHub-reviewed advisory GHSA-542m-9234-8gvf lists affected ranges: PyPI vllm >=0.19.0 <0.32.0)
- Verified: https://osv.dev/vulnerability/GHSA-542m-9234-8gvf (OSV record GHSA-542m-9234-8gvf lists affected ranges: PyPI vllm >=0.19.0 <0.32.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4344 (OSV record PYSEC-2026-4344 lists affected ranges: PyPI vllm >=0.19.0 <0.32.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…