Skip to content

← Actionable
Medium, CVSS 6.8amended

Python Social Auth: OpenID Connect nonce is not bound to the browser session, so a stolen authorization code logs the attacker in as the victim

CVE-2026-115910GHSA-h2r5-x5m7-3935

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-core 6.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-115910: 0.16% estimated exploitation activity in the next 30 days; percentile 4.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The generic OpenID Connect backend (`OpenIdConnectAuth` and every backend built on it) stores the `nonce` in the shared Association table, not in the user's session. When the ID token comes back, `validate_claims` only checks that the nonce exists in that table and is not expired. It does not check that the nonce was issued to the browser that is finishing the login. So the nonce does not do its job. OIDC Core (section 15.5.2) and RFC 9700 (section 4.5) use the nonce to stop authorization code injection: an attacker who gets hold of a victim's unused authorization code should not be able to redeem it in the attacker's own browser. With social-auth-core, the attacker can. They start their own login to get a valid `state` for their session, then hit the callback with the victim's `code` and their own `state`. `state` passes because it belongs to the attacker's session, and the nonce in the victim's ID token passes because it is in the global table. The attacker's browser is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-h2r5-x5m7-3935

  2. Revision 1 · created ·

    Published from ghsa record GHSA-h2r5-x5m7-3935

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115910

Advisory: Python Social Auth: OpenID Connect nonce is not bound to the browser session, so a stolen authorization code logs the attacker in as the victim
IDs: CVE-2026-115910, GHSA-h2r5-x5m7-3935
Record: https://patchnext.com/advisories/cve-2026-115910 (revision 2, source checked 29 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: social-auth-core 6.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI social-auth-core: affected < 6.2.0; fixed in 6.2.0

## Suggested inspection (read-only)
- `python -m pip show social-auth-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on social-auth-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h2r5-x5m7-3935 (OSV record GHSA-h2r5-x5m7-3935 lists affected ranges: PyPI social-auth-core >=0 <6.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h2r5-x5m7-3935 (GitHub-reviewed advisory GHSA-h2r5-x5m7-3935 lists affected ranges: PyPI social-auth-core >=0 <=6.1.1)

Commands are suggestions: review each one before running it.

Loading voting…