zip: legacy Shrink/Reduce/Implode decoder: denial of service from attacker-controlled ZIP64 uncompressed size
CVE-2026-115907GHSA-9hj8-73fh-9963
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zip 9.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io zip
- Affected
- >= 5.1.0, < 9.0.0
- Fixed in
- 9.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9hj8-73fh-9963 lists affected ranges: crates.io zip >=5.1.0 <9.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9hj8-73fh-9963 lists affected ranges: crates.io zip >=5.1.0 <9.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-115907: 0.35% estimated exploitation activity in the next 30 days; percentile 28.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A malicious 149-byte ZIP archive can cause a denial of service in applications that enable `legacy-zip` and use `ZipArchive::extract()`. An attacker-controlled ZIP64 uncompressed size triggers a `capacity overflow` panic in the Shrink decoder in optimized builds, potentially terminating the affected process.
Details When reading a Shrink-compressed entry, `ShrinkDecoder::read()` buffers the compressed input and reserves output capacity using the entry's declared uncompressed size: ```rust if !self.stream_read { self.stream_read = true; let mut compressed_bytes = Vec::new(); self.compressed_reader.read_to_end(&mut compressed_bytes)?; self.stream.reserve(self.uncompressed_size as usize); hwunshrink( &compressed_bytes, self.uncompressed_size as usize, &mut self.stream, )?; } ``` In version 8.6.0, this is located in `src/legacy/shrink.rs`. The vulnerable legacy…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-9hj8-73fh-9963
- Revision 1 · created ·
Published from ghsa record GHSA-9hj8-73fh-9963
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-115907 Advisory: zip: legacy Shrink/Reduce/Implode decoder: denial of service from attacker-controlled ZIP64 uncompressed size IDs: CVE-2026-115907, GHSA-9hj8-73fh-9963 Record: https://patchnext.com/advisories/cve-2026-115907 (revision 2, source checked 30 Oct 2026, 07:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zip 9.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io zip: affected >= 5.1.0, < 9.0.0; fixed in 9.0.0 ## Suggested inspection (read-only) - crates.io zip: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zip. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9hj8-73fh-9963 (GitHub-reviewed advisory GHSA-9hj8-73fh-9963 lists affected ranges: crates.io zip >=5.1.0 <9.0.0) - Verified: https://osv.dev/vulnerability/GHSA-9hj8-73fh-9963 (OSV record GHSA-9hj8-73fh-9963 lists affected ranges: crates.io zip >=5.1.0 <9.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…