graphql-scalars PhoneNumber scalar is vulnerable to regular expression denial of service
CVE-2026-115887GHSA-x8rm-f576-gq67
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphql-scalars 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm graphql-scalars
- Affected
- >= 1.24.1, < 2.0.1
- Fixed in
- 2.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x8rm-f576-gq67 lists affected ranges: npm graphql-scalars >=0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x8rm-f576-gq67 lists affected ranges: npm graphql-scalars >=0 <=2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x8rm-f576-gq67 lists affected ranges: npm graphql-scalars >=1.24.1 <=2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x8rm-f576-gq67 lists affected ranges: npm graphql-scalars >=1.24.1 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-115887: 0.49% estimated exploitation activity in the next 30 days; percentile 41.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The regular expression behind `GraphQLPhoneNumber` since 1.24.1 backtracks exponentially. A string made of a run of digits followed by one character that makes the match fail (for example `"1".repeat(30) + "x"`) blocks the JavaScript thread for seconds, and every additional digit doubles the time. graphql-js calls `parseLiteral` while *validating* a document and `parseValue` while coercing variables, so the regex runs for every request that merely contains such a value in a `PhoneNumber` position, before execution and before any authentication or authorization step of the server. One small unauthenticated request is enough to stall a server process.
Affected versions - `graphql-scalars` >= 1.24.1, <= 2.0.0 (2.0.0 is the current `latest`; the default branch still has the same pattern). - Not affected: 1.24.0 and the earlier versions I checked (1.22.4, 1.23.0), which use the linear `/^\+[1-9]\d{6,14}$/`. - Introduced by #2719 (c7f58da16, "PhoneNumber scalar is not fully…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-x8rm-f576-gq67
- Revision 3 · amended ·
Amended from ghsa record GHSA-x8rm-f576-gq67
- Revision 2 · amended ·
Amended from osv record GHSA-x8rm-f576-gq67
- Revision 1 · created ·
Published from ghsa record GHSA-x8rm-f576-gq67
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-115887 Advisory: graphql-scalars PhoneNumber scalar is vulnerable to regular expression denial of service IDs: CVE-2026-115887, GHSA-x8rm-f576-gq67 Record: https://patchnext.com/advisories/cve-2026-115887 (revision 4, source checked 31 Oct 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: graphql-scalars 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm graphql-scalars: affected >= 1.24.1, < 2.0.1; fixed in 2.0.1 ## Suggested inspection (read-only) - `npm ls graphql-scalars --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on graphql-scalars. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x8rm-f576-gq67 (OSV record GHSA-x8rm-f576-gq67 lists affected ranges: npm graphql-scalars >=0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-x8rm-f576-gq67 (GitHub-reviewed advisory GHSA-x8rm-f576-gq67 lists affected ranges: npm graphql-scalars >=0 <=2.0.0) - Verified: https://github.com/advisories/GHSA-x8rm-f576-gq67 (GitHub-reviewed advisory GHSA-x8rm-f576-gq67 lists affected ranges: npm graphql-scalars >=1.24.1 <=2.0.0) - Verified: https://osv.dev/vulnerability/GHSA-x8rm-f576-gq67 (OSV record GHSA-x8rm-f576-gq67 lists affected ranges: npm graphql-scalars >=1.24.1 <2.0.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…