Skip to content

← Actionable
Medium, CVSS 6.5amended

MLflow: SSRF on unauthenticated MLflow servers via third-party scorer kwargs in the scorer invoke, register, and GenAI evaluate endpoints

CVE-2026-115886GHSA-2wqp-q3c6-ccj5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 3.17.0; mlflow 3.17.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mlflow

    Affected
    >= 3.12.0rc0, < 3.17.0
    Fixed in
    3.17.0
  • Bitnami mlflow

    Affected
    >= 3.12.0, < 3.17.0
    Fixed in
    3.17.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-115886: 0.68% estimated exploitation activity in the next 30 days; percentile 52.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary MLflow's tracking server exposes `POST /ajax-api/3.0/mlflow/scorer/invoke` with no authentication, and the handler reflectively instantiates an attacker-named class from attacker-supplied JSON with unconstrained constructor kwargs. With the optional `trulens` + `trulens-providers-litellm` packages installed, an unauthenticated attacker can force the server to make an outbound HTTP request to an arbitrary host of their choosing, carrying attacker-controlled headers (SSRF).

Details `Scorer.model_validate_json()` reflects a class name from a JSON payload behind an import-path allowlist that never constrains the reflected attribute or its kwargs, in `mlflow/genai/scorers/base.py:549-604`: ```python data = serialized.third_party_scorer_data

attacker JSON module_path = data.get("module") or "" class_name = data.get("class") if not any(module_path == m or module_path.startswith(m + ".") for m in THIRD_PARTY_SCORER_ALLOWED_MODULES): raise…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record BIT-mlflow-2026-115886

  2. Revision 4 · amended ·

    Amended from osv record GHSA-2wqp-q3c6-ccj5

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-2wqp-q3c6-ccj5

  4. Revision 2 · amended ·

    Amended from osv record GHSA-2wqp-q3c6-ccj5

  5. Revision 1 · created ·

    Published from ghsa record GHSA-2wqp-q3c6-ccj5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115886

Advisory: MLflow: SSRF on unauthenticated MLflow servers via third-party scorer kwargs in the scorer invoke, register, and GenAI evaluate endpoints
IDs: CVE-2026-115886, GHSA-2wqp-q3c6-ccj5
Record: https://patchnext.com/advisories/cve-2026-115886 (revision 5, source checked 30 Oct 2026, 07:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mlflow 3.17.0; mlflow 3.17.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mlflow: affected >= 3.12.0rc0, < 3.17.0; fixed in 3.17.0
- Bitnami mlflow: affected >= 3.12.0, < 3.17.0; fixed in 3.17.0

## Suggested inspection (read-only)
- `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active.
- Bitnami mlflow: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mlflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2wqp-q3c6-ccj5 (GitHub-reviewed advisory GHSA-2wqp-q3c6-ccj5 lists affected ranges: PyPI mlflow >=3.12.0rc0 <3.17.0)
- Verified: https://osv.dev/vulnerability/GHSA-2wqp-q3c6-ccj5 (OSV record GHSA-2wqp-q3c6-ccj5 lists affected ranges: PyPI mlflow >=3.12.0rc0 <3.17.0 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-mlflow-2026-115886 (OSV record BIT-mlflow-2026-115886 lists affected ranges: Bitnami mlflow >=3.12.0 <3.17.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…