Skip to content

← Actionable
Medium, CVSS 4.1amended

LangGraph CLI prints the registry push token in langgraph deploy --verbose output

CVE-2026-115885GHSA-8prr-f582-jqq3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-cli 0.4.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.1 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-115885: 0.11% estimated exploitation activity in the next 30 days; percentile 1.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary `langgraph deploy --verbose` printed the temporary registry push token that the CLI uses to log Docker in to the deployment's image registry. Anyone who could read that output, for example in CI logs, could use the token until it expired.

Details When Docker is available, `langgraph deploy` builds the image locally, requests a push token from LangSmith, and runs `docker login --password-stdin` with the token on stdin. The CLI's subprocess helper printed each command's stdin when verbose output was on, and the login step inherited `--verbose`, so the token was printed right after the `docker login` command line. `langgraph-cli` 0.4.15 through 0.4.31 are affected. Starting with 0.4.32, the login step runs without verbose output. Deploys run without `--verbose`, and deploys that build the image remotely, never printed the token.

Impact You may be affected if you ran `langgraph deploy --verbose` with an affected version and the output was kept or shared, for example…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-8prr-f582-jqq3

  2. Revision 1 · created ·

    Published from ghsa record GHSA-8prr-f582-jqq3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115885

Advisory: LangGraph CLI prints the registry push token in `langgraph deploy --verbose` output
IDs: CVE-2026-115885, GHSA-8prr-f582-jqq3
Record: https://patchnext.com/advisories/cve-2026-115885 (revision 2, source checked 29 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langgraph-cli 0.4.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langgraph-cli: affected >= 0.4.15, < 0.4.32; fixed in 0.4.32

## Suggested inspection (read-only)
- `python -m pip show langgraph-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langgraph-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8prr-f582-jqq3 (GitHub-reviewed advisory GHSA-8prr-f582-jqq3 lists affected ranges: PyPI langgraph-cli >=0.4.15 <=0.4.31)
- Verified: https://osv.dev/vulnerability/GHSA-8prr-f582-jqq3 (OSV record GHSA-8prr-f582-jqq3 lists affected ranges: PyPI langgraph-cli >=0.4.15 <0.4.32 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…