Skip to content

← Actionable
High, CVSS 7.8amended

Stanza: RCE via pickle deserialization in the lemmatizer

CVE-2026-115878GHSA-gh9r-c94j-cmp5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (stanza 1.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI stanza

    Affected
    >= 1.14.0, < 1.15.0
    Fixed in
    1.15.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

TL;DR Loading an attacker-supplied lemma `.pt` runs arbitrary code as the loading user. Since 1.14.0 the lemmatizer stores `pos_dict` as a gzip-compressed pickle in the checkpoint's `dicts` field (a `bytes` value). `torch.load(weights_only=True)` treats `bytes` as a primitive and passes it through unexamined, so its allowlist never sees the inner stream. `Trainer.load` then feeds those bytes to an unrestricted `pickle.loads`: the only bare `pickle.loads` in the tree. Result: `weights_only=True` gives no protection here, and model loading executes code. Confirmed end-to-end against stanza 1.14.0 / PyTorch 2.13.0 / CPython 3.13.7: a crafted checkpoint whose payload `reduce` returns `(os.system, (cmd,))` ran the command at load time (marker file showed `uid=501(...)`, `executed_by=...`). A downstream user is vulnerable whenever they build a pipeline that loads a caller-supplied lemmatizer checkpoint. i.e. `stanza.Pipeline(lang=..., processors="tokenize,pos,lemma",…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-gh9r-c94j-cmp5

  2. Revision 1 · created ·

    Published from ghsa record GHSA-gh9r-c94j-cmp5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115878

Advisory: Stanza: RCE via pickle deserialization in the lemmatizer
IDs: CVE-2026-115878, GHSA-gh9r-c94j-cmp5
Record: https://patchnext.com/advisories/cve-2026-115878 (revision 2, source checked 4 Nov 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: stanza 1.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI stanza: affected >= 1.14.0, < 1.15.0; fixed in 1.15.0

## Suggested inspection (read-only)
- `python -m pip show stanza`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on stanza.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gh9r-c94j-cmp5 (GitHub-reviewed advisory GHSA-gh9r-c94j-cmp5 lists affected ranges: PyPI stanza >=1.14.0 <=1.14.0)
- Verified: https://osv.dev/vulnerability/GHSA-gh9r-c94j-cmp5 (OSV record GHSA-gh9r-c94j-cmp5 lists affected ranges: PyPI stanza >=1.14.0 <1.15.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…