Skip to content

← Actionable
High, CVSS 7.5amended

Twisted: Unauthenticated Remote Denial of Service in the Twisted conch Telnet Transport via an Unbounded Subnegotiation Buffer

CVE-2026-115778GHSA-cwm5-jh59-mwxr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twisted 26.10.0rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI twisted

    Affected
    <= 26.4.0
    Fixed in
    26.10.0rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-115778: 0.54% estimated exploitation activity in the next 30 days; percentile 45.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An allocation-without-limits vulnerability (CWE-770) in the Twisted conch telnet transport lets any unauthenticated remote peer exhaust server memory over a single connection. When the peer opens a telnet subnegotiation with IAC SB and then streams bytes without ever sending the IAC SE terminator, every byte is appended to a per-connection buffer that has no maximum length. The buffer persists across reads and is released only on the terminator the attacker withholds, so it grows without bound until the process is killed. Details The option-negotiation state machine in Telnet.dataReceived enters the subnegotiation state on IAC SB and sets an empty command list. In that state every non-IAC byte is appended to the list with no length check: self.commands is an instance attribute that persists across dataReceived calls and is deleted only when IAC SE completes the subnegotiation. Negotiation runs at the transport layer before authentication, and the bytes are consumed inside…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cwm5-jh59-mwxr

  2. Revision 2 · amended ·

    Amended from osv record GHSA-cwm5-jh59-mwxr

  3. Revision 1 · created ·

    Published from ghsa record GHSA-cwm5-jh59-mwxr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115778

Advisory: Twisted: Unauthenticated Remote Denial of Service in the Twisted conch Telnet Transport via an Unbounded Subnegotiation Buffer
IDs: CVE-2026-115778, GHSA-cwm5-jh59-mwxr
Record: https://patchnext.com/advisories/cve-2026-115778 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twisted 26.10.0rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI twisted: affected <= 26.4.0; fixed in 26.10.0rc1

## Suggested inspection (read-only)
- `python -m pip show twisted`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twisted.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cwm5-jh59-mwxr (GitHub-reviewed advisory GHSA-cwm5-jh59-mwxr lists affected ranges: PyPI twisted >=0 <=26.4.0)
- Verified: https://osv.dev/vulnerability/GHSA-cwm5-jh59-mwxr (OSV record GHSA-cwm5-jh59-mwxr lists affected ranges: PyPI twisted >=0 <26.10.0rc1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…