Skip to content

← Actionable
Medium, CVSS 4.9amended

Twisted: Denial of Service in the Twisted IMAP4 Server via a Negative Literal Size in SEARCH

CVE-2026-115774GHSA-2qrf-pqgx-qh9v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twisted 26.10.0rc1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI twisted

    Affected
    <= 26.4.0
    Fixed in
    26.10.0rc1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-115774: 0.52% estimated exploitation activity in the next 30 days; percentile 44.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An infinite-loop vulnerability (CWE-835) in the Twisted IMAP4 server lets an authenticated client freeze the whole process with one small command. twisted.mail.imap4.parseNestedParens reads an IMAP literal size with int() and never rejects a negative value. A negative size such as {-100} drives the parser cursor negative, and because a negative Python index wraps around the end of the string instead of raising, the scanning loop never terminates. It runs synchronously on the single-threaded reactor, so one SEARCH command holds the reactor at full CPU forever and every other connection stops being served. Details Meeting an inline literal, parseNestedParens reads the size between the braces and advances the cursor past the body: int(b"-100") is -100, so i goes negative; the loop condition i < len(s) stays true and s[i : i + 1] on a negative index never raises, so the cursor cycles forever. The literalStringLimit guard only covers the synchronizing-literal continuation path,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2qrf-pqgx-qh9v

  2. Revision 2 · amended ·

    Amended from osv record GHSA-2qrf-pqgx-qh9v

  3. Revision 1 · created ·

    Published from ghsa record GHSA-2qrf-pqgx-qh9v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115774

Advisory: Twisted: Denial of Service in the Twisted IMAP4 Server via a Negative Literal Size in SEARCH
IDs: CVE-2026-115774, GHSA-2qrf-pqgx-qh9v
Record: https://patchnext.com/advisories/cve-2026-115774 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twisted 26.10.0rc1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI twisted: affected <= 26.4.0; fixed in 26.10.0rc1

## Suggested inspection (read-only)
- `python -m pip show twisted`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twisted.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2qrf-pqgx-qh9v (GitHub-reviewed advisory GHSA-2qrf-pqgx-qh9v lists affected ranges: PyPI twisted >=0 <=26.4.0)
- Verified: https://osv.dev/vulnerability/GHSA-2qrf-pqgx-qh9v (OSV record GHSA-2qrf-pqgx-qh9v lists affected ranges: PyPI twisted >=0 <26.10.0rc1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…