i18next-http-backend: Namespace value starting with / forms a protocol-relative URL when loadPath/addPath places {{ns}} right after a / (bypass of the // check added for GHSA-xvq9-wjp8-hwqf)
CVE-2026-115730GHSA-9jhj-wvmw-cfx5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next-http-backend 4.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.0.3
- Fixed in
- 4.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jhj-wvmw-cfx5 lists affected ranges: npm i18next-http-backend >=0 <4.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9jhj-wvmw-cfx5 lists affected ranges: npm i18next-http-backend >=0 <4.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-115730: 0.32% estimated exploitation activity in the next 30 days; percentile 24.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions Verified on 4.0.2 (latest on npm) and on commit 07e0288 (the GHSA-xvq9-wjp8-hwqf fix). Earlier 3.x/4.x versions that allow / in ns are likely affected too. Not verified on them. Impact Same class as GHSA-xvq9-wjp8-hwqf and GHSA-q89c-q3h5-w34g: when an attacker controls the namespace value, the request goes to an attacker-chosen origin. In a browser this loads attacker-controlled translation JSON (content injection into the UI, and XSS where translations are rendered as HTML). The precondition is a template with {{ns}} right after a leading /, for example /{{ns}}/{{lng}}.json. The 4.0.2 maintainer note says templates with a leading / are safe. This case is outside that statement. Root cause isSafeNsUrlSegment rejects any ns containing //, but allows a single leading / (needed for nested namespaces like a/b). Interpolation into /{{ns}}/... puts the template's own / next to the value's /. The result starts with //, which is a protocol-relative URL. The check runs on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-9jhj-wvmw-cfx5
- Revision 2 · amended ·
Amended from ghsa record GHSA-9jhj-wvmw-cfx5
- Revision 1 · created ·
Published from ghsa record GHSA-9jhj-wvmw-cfx5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-115730
Advisory: i18next-http-backend: Namespace value starting with / forms a protocol-relative URL when loadPath/addPath places {{ns}} right after a / (bypass of the // check added for GHSA-xvq9-wjp8-hwqf)
IDs: CVE-2026-115730, GHSA-9jhj-wvmw-cfx5
Record: https://patchnext.com/advisories/cve-2026-115730 (revision 3, source checked 29 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: i18next-http-backend 4.0.3. A vendor fix does not mean a deployment is fixed.
## Affected components
- npm i18next-http-backend: affected < 4.0.3; fixed in 4.0.3
## Suggested inspection (read-only)
- `npm ls i18next-http-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on i18next-http-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-9jhj-wvmw-cfx5 (GitHub-reviewed advisory GHSA-9jhj-wvmw-cfx5 lists affected ranges: npm i18next-http-backend >=0 <4.0.3)
- Verified: https://osv.dev/vulnerability/GHSA-9jhj-wvmw-cfx5 (OSV record GHSA-9jhj-wvmw-cfx5 lists affected ranges: npm i18next-http-backend >=0 <4.0.3 (fixed))
Commands are suggestions: review each one before running it.Loading voting…