@hapi/content: Regular Expression Denial of Service (ReDoS) in HTTP header parsing
CVE-2026-115728GHSA-jg4p-7fhp-p32p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hapi/content 6.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @hapi/content
- Affected
- <= 6.0.0
- Fixed in
- 6.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jg4p-7fhp-p32p lists affected ranges: npm @hapi/content >=0 <6.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jg4p-7fhp-p32p lists affected ranges: npm @hapi/content >=0 <=6.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-115728: 0.47% estimated exploitation activity in the next 30 days; percentile 40.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2026-35213: 0.33% estimated exploitation activity in the next 30 days; percentile 25.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
All versions of @hapi/content through 6.0.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via crafted HTTP header values. Three regular expressions used to parse Content-Type and Content-Disposition headers contain patterns susceptible to catastrophic backtracking. This has been fixed in v6.0.1. Impact Denial of Service. An unauthenticated remote attacker can cause a Node.js process to become unresponsive by sending a single HTTP request with a maliciously crafted header value. Patches Fixed by tightening all three regular expressions to eliminate backtracking. Workarounds There are no known workarounds. Upgrade to the patched version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jg4p-7fhp-p32p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jg4p-7fhp-p32p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-115728 Advisory: @hapi/content: Regular Expression Denial of Service (ReDoS) in HTTP header parsing IDs: CVE-2026-115728, GHSA-jg4p-7fhp-p32p Record: https://patchnext.com/advisories/cve-2026-115728 (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @hapi/content 6.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @hapi/content: affected <= 6.0.0; fixed in 6.0.1 ## Suggested inspection (read-only) - `npm ls @hapi/content --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @hapi/content. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jg4p-7fhp-p32p (OSV record GHSA-jg4p-7fhp-p32p lists affected ranges: npm @hapi/content >=0 <6.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jg4p-7fhp-p32p (GitHub-reviewed advisory GHSA-jg4p-7fhp-p32p lists affected ranges: npm @hapi/content >=0 <=6.0.0) Commands are suggestions: review each one before running it.
Loading voting…