Skip to content

← Actionable
High, CVSS 7.1amended

virtualenv: Bash activator leaves the --prompt value unescaped in PS1 when promptvars is off, so prompt expansion later executes it (regression in 21.14.9)

CVE-2026-115586GHSA-cx6f-vjhg-g3cc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.14.13; virtualenv 21.14.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI virtualenv

    Affected
    >= 21.14.9, < 21.14.13
    Fixed in
    21.14.13
  • Bitnami virtualenv

    Affected
    >= 21.14.9, < 21.14.13
    Fixed in
    21.14.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-115586: 0.27% estimated exploitation activity in the next 30 days; percentile 19.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The bash activator puts the caller-supplied prompt value into `PS1` unescaped whenever `promptvars` is off at activation time, and assumes prompt expansion can never run afterwards. `promptvars` and posix mode are runtime shell state, not a property of the activation moment: re-enabling prompt expansion in the same shell (`shopt -s promptvars`, `set -o posix`) or starting an interactive child bash that inherits the exported `PS1` makes bash expand the stored value and run the command substitution in it. An attacker who controls the prompt value gets command execution as the user who sources `bin/activate`. This is a regression. 21.14.8 escaped `$` and the backtick unconditionally and stays inert under the same sequence. The 21.14.9 fix for GHSA-6w3r-xr62-4xcp (#3418) rewrote that block and left bash with a path that stores the raw value whenever `promptvars` is off.

Affected area Activation scripts (activate, activate.bat, activate.csh, activate.fish, activate.nu,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 7 · amended ·

    Amended from osv record BIT-virtualenv-2026-115586

  2. Revision 6 · amended ·

    Amended from osv record GHSA-cx6f-vjhg-g3cc

  3. Revision 5 · amended ·

    Amended from ghsa record GHSA-cx6f-vjhg-g3cc

  4. Revision 4 · amended ·

    Amended from ghsa record GHSA-cx6f-vjhg-g3cc

  5. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  6. Revision 2 · amended ·

    Amended from osv record GHSA-cx6f-vjhg-g3cc

  7. Revision 1 · created ·

    Published from ghsa record GHSA-cx6f-vjhg-g3cc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115586

Advisory: virtualenv: Bash activator leaves the --prompt value unescaped in PS1 when promptvars is off, so prompt expansion later executes it (regression in 21.14.9)
IDs: CVE-2026-115586, GHSA-cx6f-vjhg-g3cc
Record: https://patchnext.com/advisories/cve-2026-115586 (revision 7, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.14.13; virtualenv 21.14.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI virtualenv: affected >= 21.14.9, < 21.14.13; fixed in 21.14.13
- Bitnami virtualenv: affected >= 21.14.9, < 21.14.13; fixed in 21.14.13

## Suggested inspection (read-only)
- `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active.
- Bitnami virtualenv: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on virtualenv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cx6f-vjhg-g3cc (GitHub-reviewed advisory GHSA-cx6f-vjhg-g3cc lists affected ranges: PyPI virtualenv >=21.14.9 <21.14.13)
- Verified: https://osv.dev/vulnerability/GHSA-cx6f-vjhg-g3cc (OSV record GHSA-cx6f-vjhg-g3cc lists affected ranges: PyPI virtualenv >=21.14.9 <21.14.13 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-virtualenv-2026-115586 (OSV record BIT-virtualenv-2026-115586 lists affected ranges: Bitnami virtualenv >=21.14.9 <21.14.13 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…