Skip to content

← Actionable
High, CVSS 7.4amended

Electron: Mitigation for compromised eMudhra intermediate certificates

CVE-2026-115570GHSA-jr5w-w6x2-84p9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 45.0.0-beta.6, 44.9.1, 43.8.1, 42.11.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electron

    Affected
    >= 45.0.0-alpha.1, < 45.0.0-beta.6>= 44.0.0-alpha.1, < 44.9.1>= 43.0.0-alpha.1, < 43.8.1< 42.11.16
    Fixed in
    45.0.0-beta.6, 44.9.1, 42.11.16, 43.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-115570: 0.38% estimated exploitation activity in the next 30 days; percentile 31.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A set of eMudhra intermediate certificates were compromised and are being blocked by browsers and other TLS clients. This Electron update adds the same block to both Chromium networking and Node.js tls, https and fetch. On earlier versions, an attacker holding a certificate issued through these intermediates and able to intercept network traffic could impersonate a TLS server to an app. Apps are only affected if they make TLS connections over a network an attacker can intercept. Apps that make no network connections are not affected. Other software has shipped the same mitigation, including Go (CVE-2026-111943) and Firefox (CVE-2026-113470). Workarounds There are no app side workarounds, you must update to a patched version of Electron. Fixed Versions 45.0.0-beta.6 44.9.1 43.8.1 42.11.16 For more information If you have any questions or comments about this advisory, email us at security@electronjs.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jr5w-w6x2-84p9

  2. Revision 2 · amended ·

    Amended from osv record GHSA-jr5w-w6x2-84p9

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jr5w-w6x2-84p9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115570

Advisory: Electron: Mitigation for compromised eMudhra intermediate certificates
IDs: CVE-2026-115570, GHSA-jr5w-w6x2-84p9
Record: https://patchnext.com/advisories/cve-2026-115570 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electron 45.0.0-beta.6, 44.9.1, 43.8.1, 42.11.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electron: affected >= 45.0.0-alpha.1, < 45.0.0-beta.6; >= 44.0.0-alpha.1, < 44.9.1; >= 43.0.0-alpha.1, < 43.8.1; < 42.11.16; fixed in 45.0.0-beta.6, 44.9.1, 42.11.16, 43.8.1

## Suggested inspection (read-only)
- `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electron.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jr5w-w6x2-84p9 (GitHub-reviewed advisory GHSA-jr5w-w6x2-84p9 lists affected ranges: npm electron >=45.0.0-alpha.1 =44.0.0-alpha.1 =43.0.0-alpha.1 =0 <42.11.16)
- Verified: https://osv.dev/vulnerability/GHSA-jr5w-w6x2-84p9 (OSV record GHSA-jr5w-w6x2-84p9 lists affected ranges: npm electron >=45.0.0-alpha.1 =44.0.0-alpha.1 =43.0.0-alpha.1 =0 <42.11.16 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…