Fallow: Jest and Vitest projects entries let an analyzed repository make Fallow read files outside the project root
CVE-2026-115569GHSA-jfwm-3p3c-6hx5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fallow-cli/fallow-node 3.34.0; fallow 3.34.0; fallow-cli 3.34.0; fallow-core 3.34.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.68.0, < 3.34.0
- Fixed in
- 3.34.0
npm fallow
- Affected
- >= 2.68.0, < 3.34.0
- Fixed in
- 3.34.0
crates.io fallow-cli
- Affected
- >= 2.68.0, < 3.34.0
- Fixed in
- 3.34.0
crates.io fallow-core
- Affected
- >= 2.68.0, < 3.34.0
- Fixed in
- 3.34.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfwm-3p3c-6hx5 lists affected ranges: npm fallow >=2.68.0 =2.68.0 <3.34.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jfwm-3p3c-6hx5 lists affected ranges: npm fallow >=2.68.0 =2.68.0 =2.68.0 =2.68.0 <3.34.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jfwm-3p3c-6hx5 lists affected ranges: npm fallow >=2.68.0 =2.68.0 =2.68.0 =2.68.0 <3.34.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.3 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-115569: 0.19% estimated exploitation activity in the next 30 days; percentile 8.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Fallow reads the Jest and Vitest configs of the repository that it analyzes. A Jest projects entry or a Vitest test.projects entry can name a path. Fallow followed such an entry to a config file and read that file, also when the file was outside the project root. These forms reached outside the root: - an absolute path or glob, for example /etc/; - a path with .. segments, for example ../; - a glob with a . segment, because the glob crate also tests .. against a segment that starts with a literal .; - a symlink in the project root to a directory above it; - the extends path of a Vitest inline project; - a script --config path that is a symlink to a file outside the project root. Fallow parsed each of these files as a test runner config. Fallow used the content only to credit dependencies, setup files and JSX import sources. Thus unused dependency and unused file findings could change. Fallow did not print the content or send it over the network. The Fallow threat model states…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-jfwm-3p3c-6hx5
- Revision 3 · amended ·
Amended from ghsa record GHSA-jfwm-3p3c-6hx5
- Revision 2 · amended ·
Amended from osv record GHSA-jfwm-3p3c-6hx5
- Revision 1 · created ·
Published from ghsa record GHSA-jfwm-3p3c-6hx5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-115569 Advisory: Fallow: Jest and Vitest `projects` entries let an analyzed repository make Fallow read files outside the project root IDs: CVE-2026-115569, GHSA-jfwm-3p3c-6hx5 Record: https://patchnext.com/advisories/cve-2026-115569 (revision 4, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fallow-cli/fallow-node 3.34.0; fallow 3.34.0; fallow-cli 3.34.0; fallow-core 3.34.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fallow-cli/fallow-node: affected >= 2.68.0, < 3.34.0; fixed in 3.34.0 - npm fallow: affected >= 2.68.0, < 3.34.0; fixed in 3.34.0 - crates.io fallow-cli: affected >= 2.68.0, < 3.34.0; fixed in 3.34.0 - crates.io fallow-core: affected >= 2.68.0, < 3.34.0; fixed in 3.34.0 ## Suggested inspection (read-only) - `npm ls @fallow-cli/fallow-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls fallow --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - crates.io fallow-cli: check the installed version with your package manager. - crates.io fallow-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fallow-cli/fallow-node, fallow, fallow-cli, fallow-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jfwm-3p3c-6hx5 (GitHub-reviewed advisory GHSA-jfwm-3p3c-6hx5 lists affected ranges: npm fallow >=2.68.0 =2.68.0 <3.34.0) - Verified: https://osv.dev/vulnerability/GHSA-jfwm-3p3c-6hx5 (OSV record GHSA-jfwm-3p3c-6hx5 lists affected ranges: npm fallow >=2.68.0 =2.68.0 =2.68.0 =2.68.0 <3.34.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jfwm-3p3c-6hx5 (GitHub-reviewed advisory GHSA-jfwm-3p3c-6hx5 lists affected ranges: npm fallow >=2.68.0 =2.68.0 =2.68.0 =2.68.0 <3.34.0) Commands are suggestions: review each one before running it.
Loading voting…