Skip to content

← Actionable
Critical, CVSS 9.4amended

Distrust compromised intermediate certificates in ssl module

CVE-2026-115557

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-min 3.15.2, 3.14.10, 3.13.18, 3.12.16, 3.11.18; libpython 3.15.2, 3.14.10, 3.13.18, 3.12.16, 3.11.18; python 3.15.2, 3.14.10, 3.13.18, 3.12.16, 3.11.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami python-min

    Affected
    < 3.11.18>= 3.12.0, < 3.12.16>= 3.13.0, < 3.13.18>= 3.14.0, < 3.14.10>= 3.15.0, < 3.15.2
    Fixed in
    3.13.18, 3.15.2, 3.11.18, 3.14.10, 3.12.16
  • Bitnami libpython

    Affected
    < 3.11.18>= 3.12.0, < 3.12.16>= 3.13.0, < 3.13.18>= 3.14.0, < 3.14.10>= 3.15.0, < 3.15.2
    Fixed in
    3.13.18, 3.15.2, 3.11.18, 3.14.10, 3.12.16
  • Bitnami python

    Affected
    < 3.11.18>= 3.12.0, < 3.12.16>= 3.13.0, < 3.13.18>= 3.14.0, < 3.14.10>= 3.15.0, < 3.15.2
    Fixed in
    3.13.18, 3.15.2, 3.11.18, 3.14.10, 3.12.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-115557: 0.53% estimated exploitation activity in the next 30 days; percentile 45.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Python has added a denylist for known compromised certificates to the "ssl" module to ensure user safety even without certificate revocation configured. Known compromised certificates will automatically be rejected regardless of the SSLContext policy configuration.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record BIT-python-min-2026-115557

  2. Revision 2 · amended ·

    Amended from osv record BIT-python-2026-115557

  3. Revision 1 · created ·

    Published from osv record BIT-libpython-2026-115557

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115557

Advisory: Distrust compromised intermediate certificates in ssl module
IDs: CVE-2026-115557
Record: https://patchnext.com/advisories/cve-2026-115557 (revision 3, source checked 31 Oct 2026, 07:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: python-min 3.15.2, 3.14.10, 3.13.18, 3.12.16, 3.11.18; libpython 3.15.2, 3.14.10, 3.13.18, 3.12.16, 3.11.18; python 3.15.2, 3.14.10, 3.13.18, 3.12.16, 3.11.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami python-min: affected < 3.11.18; >= 3.12.0, < 3.12.16; >= 3.13.0, < 3.13.18; >= 3.14.0, < 3.14.10; >= 3.15.0, < 3.15.2; fixed in 3.13.18, 3.15.2, 3.11.18, 3.14.10, 3.12.16
- Bitnami libpython: affected < 3.11.18; >= 3.12.0, < 3.12.16; >= 3.13.0, < 3.13.18; >= 3.14.0, < 3.14.10; >= 3.15.0, < 3.15.2; fixed in 3.13.18, 3.15.2, 3.11.18, 3.14.10, 3.12.16
- Bitnami python: affected < 3.11.18; >= 3.12.0, < 3.12.16; >= 3.13.0, < 3.13.18; >= 3.14.0, < 3.14.10; >= 3.15.0, < 3.15.2; fixed in 3.13.18, 3.15.2, 3.11.18, 3.14.10, 3.12.16

## Suggested inspection (read-only)
- Bitnami python-min: check the installed version with your package manager.
- Bitnami libpython: check the installed version with your package manager.
- Bitnami python: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on python-min, libpython, python.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/BIT-libpython-2026-115557 (OSV record BIT-libpython-2026-115557 lists affected ranges: Bitnami libpython >=0 =3.12.0 =3.13.0 =3.14.0 =3.15.0 <3.15.2 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-python-2026-115557 (OSV record BIT-python-2026-115557 lists affected ranges: Bitnami python >=0 =3.12.0 =3.13.0 =3.14.0 =3.15.0 <3.15.2 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-python-min-2026-115557 (OSV record BIT-python-min-2026-115557 lists affected ranges: Bitnami python-min >=0 =3.12.0 =3.13.0 =3.14.0 =3.15.0 <3.15.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…