obsidian-tc: Declined human-in-the-loop confirmations can permit destructive calls over HTTP
CVE-2026-115477GHSA-737x-cwfr-5vvc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (obsidian-tc 1.31.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm obsidian-tc
- Affected
- >= 1.13.0, <= 1.31.3
- Fixed in
- 1.31.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-737x-cwfr-5vvc lists affected ranges: npm obsidian-tc >=1.13.0 <=1.31.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-737x-cwfr-5vvc lists affected ranges: npm obsidian-tc >=1.13.0 <1.31.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-115477: 0.35% estimated exploitation activity in the next 30 days; percentile 29.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary On a Streamable HTTP deployment with auth.jwtSecret configured, serving a 2026-07-28-era client that declared elicitation.form support, a call to a dispatch-gated tool (destructive: true, or a scope with an HITL floor) that was offered an inputRequired confirmation could still complete after the human declined, cancelled, or the elicitation response was omitted or malformed, provided the client echoed the validly bound requestState on resubmission. The server trusted an authentic, call-bound state as proof of approval; the state is minted before the elicitation leg is asked, so it proves only that the resubmission belongs to the same call. Details Reproduced directly: a destructive: true tool call, offered inputRequired, answered with {action: "decline"} on the elicitation/create leg, still wrote. Present since the 2026-07-28 round trip shipped in v1.13.0 (THE-583). Only dispatch-gated tools were reachable; the sixteen handler-side conditionally gated tools (writenote…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from ghsa record GHSA-737x-cwfr-5vvc
- Revision 4 · amended ·
Amended from ghsa record GHSA-737x-cwfr-5vvc
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-737x-cwfr-5vvc
- Revision 1 · created ·
Published from ghsa record GHSA-737x-cwfr-5vvc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-115477 Advisory: obsidian-tc: Declined human-in-the-loop confirmations can permit destructive calls over HTTP IDs: CVE-2026-115477, GHSA-737x-cwfr-5vvc Record: https://patchnext.com/advisories/cve-2026-115477 (revision 5, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: obsidian-tc 1.31.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm obsidian-tc: affected >= 1.13.0, <= 1.31.3; fixed in 1.31.4 ## Suggested inspection (read-only) - `npm ls obsidian-tc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on obsidian-tc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-737x-cwfr-5vvc (GitHub-reviewed advisory GHSA-737x-cwfr-5vvc lists affected ranges: npm obsidian-tc >=1.13.0 <=1.31.3) - Verified: https://osv.dev/vulnerability/GHSA-737x-cwfr-5vvc (OSV record GHSA-737x-cwfr-5vvc lists affected ranges: npm obsidian-tc >=1.13.0 <1.31.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…