Skip to content

← Actionable
High, CVSS 8.6amended

Strands Agents SDK: Exposure of data element to wrong session in the A2A Server

CVE-2026-115419GHSA-4v6f-7vjh-6x4m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strands-agents/sdk 1.5.0; strands-agents 1.43.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-115419: 0.43% estimated exploitation activity in the next 30 days; percentile 36.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Strands Agents SDK is an open-source SDK, available for Python (strands-agents) and TypeScript (@strands-agents/sdk), for building and running AI agents. An issue exists where, under certain circumstances, the Agent2Agent (A2A) server shares conversation history across callers with different context\id values, allowing one caller to read and influence another caller's session. Impact The A2A server did not properly isolate conversation state between callers. In multi-tenant deployments, an authenticated remote user could access another caller's conversation history or influence model behavior for other callers (CWE-488: Unintended Disclosure of Data Element to Wrong Session). This affects any deployment where an A2A server is reachable by more than one user or tenant. Impacted versions: strands-agents (Python): all versions containing the multiagent.a2a module, < 1.43.0 @strands-agents/sdk (TypeScript): < 1.5.0 Patches This issue has been addressed in strands-agents version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from ghsa record GHSA-4v6f-7vjh-6x4m

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-4v6f-7vjh-6x4m

  3. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  4. Revision 2 · amended ·

    Amended from osv record GHSA-4v6f-7vjh-6x4m

  5. Revision 1 · created ·

    Published from ghsa record GHSA-4v6f-7vjh-6x4m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115419

Advisory: Strands Agents SDK: Exposure of data element to wrong session in the A2A Server
IDs: CVE-2026-115419, GHSA-4v6f-7vjh-6x4m
Record: https://patchnext.com/advisories/cve-2026-115419 (revision 5, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strands-agents/sdk 1.5.0; strands-agents 1.43.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strands-agents/sdk: affected < 1.5.0; fixed in 1.5.0
- PyPI strands-agents: affected < 1.43.0; fixed in 1.43.0

## Suggested inspection (read-only)
- `npm ls @strands-agents/sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `python -m pip show strands-agents`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strands-agents/sdk, strands-agents.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4v6f-7vjh-6x4m (GitHub-reviewed advisory GHSA-4v6f-7vjh-6x4m lists affected ranges: PyPI strands-agents >=0 =0 <1.5.0)
- Verified: https://osv.dev/vulnerability/GHSA-4v6f-7vjh-6x4m (OSV record GHSA-4v6f-7vjh-6x4m lists affected ranges: PyPI strands-agents >=0 =0 <1.5.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…