Skip to content

← Actionable
Unrated

OpenBao before 2.6.3 ACL Bypass via Dropped Templated Policy Denial

CVE-2026-115361GHSA-hr5j-3j78-4vh2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openbao 2.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami openbao

    Affected
    < 2.6.3
    Fixed in
    2.6.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-115361: 0.21% estimated exploitation activity in the next 30 days; percentile 10.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenBao before 2.6.3 contains an ACL bypass vulnerability that silently drops explicit deny rules based on forbidden identity metadata templates within wildcard grants. Attackers whose identity metadata contains wildcard or path segments can access paths that should be denied within the broader wildcard-granted scope.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record BIT-openbao-2026-115361

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-115361

Advisory: OpenBao before 2.6.3 ACL Bypass via Dropped Templated Policy Denial
IDs: CVE-2026-115361, GHSA-hr5j-3j78-4vh2
Record: https://patchnext.com/advisories/cve-2026-115361 (revision 1, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openbao 2.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami openbao: affected < 2.6.3; fixed in 2.6.3

## Suggested inspection (read-only)
- Bitnami openbao: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openbao.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/BIT-openbao-2026-115361 (OSV record BIT-openbao-2026-115361 lists affected ranges: Bitnami openbao >=0 <2.6.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…