Weaviate has an Improper Authorization issue
CVE-2026-11500GHSA-jqpm-wf57-qx5c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/weaviate/weaviate 1.38.0-rc.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/weaviate/weaviate
- Affected
- < 1.38.0-rc.0
- Fixed in
- 1.38.0-rc.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6140 lists affected ranges: Go github.com/weaviate/weaviate >=0 <1.38.0-rc.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqpm-wf57-qx5c lists affected ranges: Go github.com/weaviate/weaviate >=0 <1.38.0-rc.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-11500: 0.34% estimated exploitation activity in the next 30 days; percentile 27.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jqpm-wf57-qx5c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GO-2026-6140
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-11500 Advisory: Weaviate has an Improper Authorization issue IDs: CVE-2026-11500, GHSA-jqpm-wf57-qx5c Record: https://patchnext.com/advisories/cve-2026-11500 (revision 3, source checked 26 Oct 2026, 15:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/weaviate/weaviate 1.38.0-rc.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/weaviate/weaviate: affected < 1.38.0-rc.0; fixed in 1.38.0-rc.0 ## Suggested inspection (read-only) - Go github.com/weaviate/weaviate: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/weaviate/weaviate. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6140 (OSV record GO-2026-6140 lists affected ranges: Go github.com/weaviate/weaviate >=0 <1.38.0-rc.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jqpm-wf57-qx5c (GitHub-reviewed advisory GHSA-jqpm-wf57-qx5c lists affected ranges: Go github.com/weaviate/weaviate >=0 <1.38.0-rc.0) Commands are suggestions: review each one before running it.
Loading voting…