Skip to content

← Actionable
Medium, CVSS 6.8amended

Authlib: Default JWT bearer grant accepts assertions for the wrong audience

CVE-2026-114618GHSA-fch4-3c6x-j4gc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI authlib

    Affected
    < 1.9.0
    Fixed in
    1.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-114618: 0.35% estimated exploitation activity in the next 30 days; percentile 28.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description

Summary Authlib's default RFC 7523 JWT bearer grant leaves `get_audiences()` empty, so `verify_claims()` only checks that an `aud` claim *exists* instead of requiring it to match the current authorization server's token endpoint. An attacker holding a legitimately issued JWT assertion for *any* audience can present it to a different authorization server sharing the same signing key and obtain an access token. To be completely transparent, AI tools helped surface it. However, we have independently reproduced and carefully validated the issue. We follow responsible disclosure practices and are sharing this privately.

Affected Entrypoints - `authlib.oauth2.rfc7523.JWTBearerGrant` — default `get_audiences()` returns empty list - `authlib.jose.jwt.decode()` with `claims_options` for audience validation - `authlib.integrations.flask_oauth2.ResourceProtector.validate_request()` when audience checking is enabled

Exploit Path ``` 1. Attacker authenticates to Service…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record PYSEC-2026-4358

  2. Revision 3 · amended ·

    Amended from osv record GHSA-fch4-3c6x-j4gc

  3. Revision 2 · amended ·

    Amended from osv record GHSA-fch4-3c6x-j4gc

  4. Revision 1 · created ·

    Published from ghsa record GHSA-fch4-3c6x-j4gc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114618

Advisory: Authlib: Default JWT bearer grant accepts assertions for the wrong audience
IDs: CVE-2026-114618, GHSA-fch4-3c6x-j4gc
Record: https://patchnext.com/advisories/cve-2026-114618 (revision 4, source checked 31 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: authlib 1.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI authlib: affected < 1.9.0; fixed in 1.9.0

## Suggested inspection (read-only)
- `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on authlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fch4-3c6x-j4gc (OSV record GHSA-fch4-3c6x-j4gc lists affected ranges: PyPI authlib >=0 <1.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fch4-3c6x-j4gc (GitHub-reviewed advisory GHSA-fch4-3c6x-j4gc lists affected ranges: PyPI authlib >=0 <1.9.0)
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4358 (OSV record PYSEC-2026-4358 lists affected ranges: PyPI authlib >=0 <1.9.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…