Skip to content

← Actionable
High, CVSS 7.4amended

Authlib accepts an empty HMAC key, allowing JWS/JWT signature forgery (HS256/HS384/HS512)

CVE-2026-114616GHSA-8m4g-j4wp-wgcg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI authlib

    Affected
    < 1.9.1
    Fixed in
    1.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-114616: 0.30% estimated exploitation activity in the next 30 days; percentile 22.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Reporter: Cavan Loughran, Celvex Group Inc. Summary Authlib's symmetric (oct) key handling accepts an empty key (empty bytes b'' / empty string '') as a valid HMAC signing and verification key. An empty HMAC key produces a deterministic digest that any party can reproduce, so an attacker who knows (or can cause) the application to verify a token with an empty key can forge arbitrary tokens that pass HS256/HS384/HS512 signature verification. This is the Authlib member of the cross-language empty-HMAC-key family already assigned CVE-2026-44351 (fast-jwt, npm) and CVE-2026-45363 (ruby-jwt, RubyGems). This is DISTINCT from Authlib's existing recent JWT-verification advisories. It is not closed by CVE-2026-27962 / GHSA-wvwj-cvrp-7pv5 (JWS JWK header injection, the key=None case), nor by CVE-2026-28802 / GHSA-7wc2-qxgw-g8gg (alg:none blank-signature bypass), nor by GHSA-5357-c2jx-v7qh (algorithm confusion with asymmetric public keys). Those address header-driven key injection, the none…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from osv record PYSEC-2026-4356

  2. Revision 3 · amended ·

    Amended from osv record GHSA-8m4g-j4wp-wgcg

  3. Revision 2 · amended ·

    Amended from osv record GHSA-8m4g-j4wp-wgcg

  4. Revision 1 · created ·

    Published from ghsa record GHSA-8m4g-j4wp-wgcg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114616

Advisory: Authlib accepts an empty HMAC key, allowing JWS/JWT signature forgery (HS256/HS384/HS512)
IDs: CVE-2026-114616, GHSA-8m4g-j4wp-wgcg
Record: https://patchnext.com/advisories/cve-2026-114616 (revision 4, source checked 31 Oct 2026, 06:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: authlib 1.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI authlib: affected < 1.9.1; fixed in 1.9.1

## Suggested inspection (read-only)
- `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on authlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8m4g-j4wp-wgcg (OSV record GHSA-8m4g-j4wp-wgcg lists affected ranges: PyPI authlib >=0 <1.9.1 (fixed))
- Verified: https://github.com/advisories/GHSA-8m4g-j4wp-wgcg (GitHub-reviewed advisory GHSA-8m4g-j4wp-wgcg lists affected ranges: PyPI authlib >=0 <1.9.1)
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4356 (OSV record PYSEC-2026-4356 lists affected ranges: PyPI authlib >=0 <1.9.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…