MessagePack: Unbounded memory leak in msgpack C extension on strict_map_key validation failure
CVE-2026-114613GHSA-j586-36cw-2gc2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (msgpack 1.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI msgpack
- Affected
- < 1.2.3
- Fixed in
- 1.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j586-36cw-2gc2 lists affected ranges: PyPI msgpack >=0 <1.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j586-36cw-2gc2 lists affected ranges: PyPI msgpack >=0 <1.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-114613: 0.54% estimated exploitation activity in the next 30 days; percentile 45.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The msgpack-python C extension (`msgpack._cmsgpack`) leaks a decoded map value when deserialization rejects a key with `strict_map_key=True` (the default). Repeated malformed inputs can cause unbounded process memory growth and denial of service in applications that deserialize attacker-controlled MessagePack data. Both `unpackb()` and the streaming `Unpacker` API are affected. The pure-Python fallback does not exhibit this leak in the reported tests. The report measured approximately 4 MiB retained per failed parse and 100 MiB after 25 failed parses on Windows with Python 3.14 and msgpack 1.2.2. These are reporter-provided results.
Additional impact: stale parser-stack references The reference-ownership audit performed while fixing this leak found an additional memory-safety issue in the streaming `Unpacker`. After `unpack()` completed a nested container, an inactive parser-stack slot could retain a non-owning pointer to the decoded object. A subsequent `skip()` could…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-j586-36cw-2gc2
- Revision 1 · created ·
Published from ghsa record GHSA-j586-36cw-2gc2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114613 Advisory: MessagePack: Unbounded memory leak in msgpack C extension on strict_map_key validation failure IDs: CVE-2026-114613, GHSA-j586-36cw-2gc2 Record: https://patchnext.com/advisories/cve-2026-114613 (revision 2, source checked 28 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: msgpack 1.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI msgpack: affected < 1.2.3; fixed in 1.2.3 ## Suggested inspection (read-only) - `python -m pip show msgpack`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on msgpack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j586-36cw-2gc2 (GitHub-reviewed advisory GHSA-j586-36cw-2gc2 lists affected ranges: PyPI msgpack >=0 <1.2.3) - Verified: https://osv.dev/vulnerability/GHSA-j586-36cw-2gc2 (OSV record GHSA-j586-36cw-2gc2 lists affected ranges: PyPI msgpack >=0 <1.2.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…