LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key
CVE-2026-114612GHSA-7hp6-4w63-5g45
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (litellm 1.104.0rc2, 1.103.1, 1.102.2, 1.101.3, 1.100.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI litellm
- Affected
- >= 1.91.0, < 1.100.4>= 1.101.0, < 1.101.3>= 1.102.0, < 1.102.2>= 1.103.0, < 1.103.1>= 1.104.0rc1, < 1.104.0rc2
- Fixed in
- 1.102.2, 1.100.4, 1.104.0rc2, 1.103.1, 1.101.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7hp6-4w63-5g45 lists affected ranges: PyPI litellm >=1.91.0 =1.101.0 =1.102.0 =1.103.0 =1.104.0rc1 <1.104.0rc2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7hp6-4w63-5g45 lists affected ranges: PyPI litellm >=1.91.0 =1.101.0 =1.102.0 =1.103.0 =1.104.0rc1 <1.104.0rc2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-114612: 0.32% estimated exploitation activity in the next 30 days; percentile 24.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated user with `internal_user` privileges can escalate to `proxy_admin` and achieve remote code execution. The proxy uses one encryption key for two purposes: sealing secrets at rest and minting session tokens. An attacker exploits this by requesting a new API key with a crafted metadata field containing a forged admin credential as the "secret" value. The proxy encrypts and returns this payload. When this value is then presented as a bearer token, the proxy decrypts it, trusts the forged admin identity, and grants full administrative access, including the ability to execute arbitrary commands via the MCP stdio endpoint.
Affected versions Versions later than 1.91.0 are exploitable in the default configuration. Versions 1.87.0 through 1.90.x are exploitable only if `EXPERIMENTAL_UI_LOGIN=true` was explicitly set.
Mitigation Upgrade to a patched version as soon as possible. If you cannot upgrade immediately, set `EXPERIMENTAL_UI_LOGIN=false`. This…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-7hp6-4w63-5g45
- Revision 1 · created ·
Published from ghsa record GHSA-7hp6-4w63-5g45
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114612 Advisory: LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key IDs: CVE-2026-114612, GHSA-7hp6-4w63-5g45 Record: https://patchnext.com/advisories/cve-2026-114612 (revision 2, source checked 28 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: litellm 1.104.0rc2, 1.103.1, 1.102.2, 1.101.3, 1.100.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI litellm: affected >= 1.91.0, < 1.100.4; >= 1.101.0, < 1.101.3; >= 1.102.0, < 1.102.2; >= 1.103.0, < 1.103.1; >= 1.104.0rc1, < 1.104.0rc2; fixed in 1.102.2, 1.100.4, 1.104.0rc2, 1.103.1, 1.101.3 ## Suggested inspection (read-only) - `python -m pip show litellm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on litellm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7hp6-4w63-5g45 (GitHub-reviewed advisory GHSA-7hp6-4w63-5g45 lists affected ranges: PyPI litellm >=1.91.0 =1.101.0 =1.102.0 =1.103.0 =1.104.0rc1 <1.104.0rc2) - Verified: https://osv.dev/vulnerability/GHSA-7hp6-4w63-5g45 (OSV record GHSA-7hp6-4w63-5g45 lists affected ranges: PyPI litellm >=1.91.0 =1.101.0 =1.102.0 =1.103.0 =1.104.0rc1 <1.104.0rc2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…