Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenTelemetry Python: Unbounded tracestate parsing in opentelemetry-api

CVE-2026-114603GHSA-xcq7-p3pf-p88h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (opentelemetry-api 1.45.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-114603: 0.49% estimated exploitation activity in the next 30 days; percentile 41.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary TraceState.fromheader splits the inbound W3C tracestate header with a regular expression that starts with an unbounded optional-whitespace run, and no length limit is applied first. A run of spaces or tabs that is not followed by a comma costs O(N²) CPU. A single unauthenticated request with a ~100 KB tracestate keeps the handling worker busy for ~6 s (spaces) to ~12 s (tabs); under an asyncio server it blocks every other connection for that time. Affected component / version - Package: opentelemetry-api (pip) — opentelemetry/trace/span.py (TraceState.fromheader), reached from opentelemetry/trace/propagation/tracecontext.py (TraceContextTextMapPropagator.extract). - Confirmed in main (5e8083e8) and in the v1.44.0 and v1.45.0 tags; the same pattern is present back to v1.0.0 (introduced by #1599, March 2021). Not exhaustively verified against every release in between. - Reachable with the default propagators (OTELPROPAGATORS defaults to tracecontext,baggage) from any server…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xcq7-p3pf-p88h

  2. Revision 2 · amended ·

    Amended from osv record GHSA-xcq7-p3pf-p88h

  3. Revision 1 · created ·

    Published from ghsa record GHSA-xcq7-p3pf-p88h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114603

Advisory: OpenTelemetry Python: Unbounded tracestate parsing in opentelemetry-api
IDs: CVE-2026-114603, GHSA-xcq7-p3pf-p88h
Record: https://patchnext.com/advisories/cve-2026-114603 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: opentelemetry-api 1.45.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI opentelemetry-api: affected <= 1.45.0; fixed in 1.45.1

## Suggested inspection (read-only)
- `python -m pip show opentelemetry-api`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on opentelemetry-api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xcq7-p3pf-p88h (GitHub-reviewed advisory GHSA-xcq7-p3pf-p88h lists affected ranges: PyPI opentelemetry-api >=0 <=1.45.0)
- Verified: https://osv.dev/vulnerability/GHSA-xcq7-p3pf-p88h (OSV record GHSA-xcq7-p3pf-p88h lists affected ranges: PyPI opentelemetry-api >=0 <1.45.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…