Skip to content

← Actionable
High, CVSS 7.1amended

Flexible GraphRAG: Cypher/Graph Injection via broken string-escaping in FalkorDB adapter (_escape()) - full graph wipe from ingested-document content

CVE-2026-114510GHSA-vqrg-773h-4wxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flexible-graphrag 0.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-114510: 0.36% estimated exploitation activity in the next 30 days; percentile 30.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description def _escape(v: str) -> str: return str(v).replace("'", "\\'").replace("\\", "\\\\") The escaping order is backwards, exactly like the classic HTML double-escape bug: step 1 inserts a literal backslash in front of every ', then step 2 re-matches that just-inserted backslash and doubles it. For an input ending in a single quote, the two steps combined produce \\' (two backslashes followed by the quote) in the output — which, under the standard backslash-escape convention used by Cypher/openCypher single-quoted string literals, is parsed as one escaped backslash followed by an unescaped, string-terminating quote. The quote is not neutralized; the string breaks open. This escaped value is interpolated directly into Cypher query strings built by string formatting (not parameters) at 5 call sites in the same method: self.lc_graph.query( f"MERGE (n:`{node.type}` {{id: '{_escape(node.id)}'}}) " f"{props}" f"RETURN distinct 'done' AS result" ) ... self.lc_graph.query( f"MATCH…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-vqrg-773h-4wxc

  2. Revision 1 · created ·

    Published from ghsa record GHSA-vqrg-773h-4wxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114510

Advisory: Flexible GraphRAG: Cypher/Graph Injection via broken string-escaping in FalkorDB adapter (_escape()) - full graph wipe from ingested-document content
IDs: CVE-2026-114510, GHSA-vqrg-773h-4wxc
Record: https://patchnext.com/advisories/cve-2026-114510 (revision 2, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flexible-graphrag 0.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flexible-graphrag: affected >= 0.6.0, < 0.8.2; fixed in 0.8.2

## Suggested inspection (read-only)
- `python -m pip show flexible-graphrag`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flexible-graphrag.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vqrg-773h-4wxc (OSV record GHSA-vqrg-773h-4wxc lists affected ranges: PyPI flexible-graphrag >=0.6.0 <0.8.2 (fixed))
- Verified: https://github.com/advisories/GHSA-vqrg-773h-4wxc (GitHub-reviewed advisory GHSA-vqrg-773h-4wxc lists affected ranges: PyPI flexible-graphrag >=0.6.0 <0.8.2)

Commands are suggestions: review each one before running it.

Loading voting…