Skip to content

← Actionable
Critical, CVSS 9.2amended

Laravel TokenGuard authentication bypass through non-string API credentials

CVE-2026-114509GHSA-f9x3-7vq9-cph6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/framework 13.29.0, 12.68.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist laravel/framework

    Affected
    >= 13.0.0, < 13.29.0< 12.68.0
    Fixed in
    12.68.0, 13.29.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-114509: 0.78% estimated exploitation activity in the next 30 days; percentile 55.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Laravel's built-in TokenGuard, when configured with a standard token-based API guard, may be bypassed to authenticate as an arbitrary existing user without knowledge of their valid API token. Under certain database configurations (MySQL/MariaDB) an attacker can submit a specially crafted, non-string credential value that is mishandled during the authentication lookup, causing the underlying query to match an unintended user record rather than failing authentication as expected. Impact An unauthenticated attacker may authenticate as another user without possessing that user's API token, leading to authentication bypass and account takeover on any route protected by the affected guard.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-f9x3-7vq9-cph6

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-f9x3-7vq9-cph6

  3. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  4. Revision 1 · created ·

    Published from osv record GHSA-f9x3-7vq9-cph6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114509

Advisory: Laravel TokenGuard authentication bypass through non-string API credentials
IDs: CVE-2026-114509, GHSA-f9x3-7vq9-cph6
Record: https://patchnext.com/advisories/cve-2026-114509 (revision 4, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: laravel/framework 13.29.0, 12.68.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist laravel/framework: affected >= 13.0.0, < 13.29.0; < 12.68.0; fixed in 12.68.0, 13.29.0

## Suggested inspection (read-only)
- Packagist laravel/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on laravel/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f9x3-7vq9-cph6 (OSV record GHSA-f9x3-7vq9-cph6 lists affected ranges: Packagist laravel/framework >=13.0.0 =0 <12.68.0 (fixed))
- Verified: https://github.com/advisories/GHSA-f9x3-7vq9-cph6 (GitHub-reviewed advisory GHSA-f9x3-7vq9-cph6 lists affected ranges: Packagist laravel/framework >=13.0.0 =0 <12.68.0)

Commands are suggestions: review each one before running it.

Loading voting…