Pillow: Arrow export leaks stale heap memory when PILLOW_ALIGNMENT > 1
CVE-2026-114501GHSA-654x-cwwv-5j9c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- >= 11.2.1, < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- >= 11.2.1, < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-654x-cwwv-5j9c lists affected ranges: PyPI pillow >=11.2.1 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-654x-cwwv-5j9c lists affected ranges: PyPI pillow >=11.2.1 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-4336 lists affected ranges: PyPI pillow >=11.2.1 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-114501 lists affected ranges: Bitnami pillow >=11.2.1 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-114501: 0.37% estimated exploitation activity in the next 30 days; percentile 30.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When `PILLOW_ALIGNMENT` is set above 1, exporting an image to Arrow returns uninitialized heap memory mixed in with the pixel data. That memory can include pixels from images the process freed earlier.
Details With an alignment above 1, the default allocator pads each row up to `aligned_linesize` and starts the first row at an aligned offset into the block. It then exports `im->blocks[0].ptr` as `xsize * ysize` tightly packed pixels, so exported data includes the padding bytes, and can include a few bytes from before the first row. Tested vulnerable on 11.2.1, 12.3.0, 4c1ed27a5.
PoC Whether things leak may depend on allocator configuration. This does show a leak on my Mac. ```python import os os.environ["PILLOW_ALIGNMENT"] = "64" from PIL import Image
Image A: 64 px wide, so its rows fill the whole aligned stride a = Image.new("L", (64, 40),…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 10 · amended ·
Amended from osv record BIT-pillow-2026-114501
- Revision 9 · amended ·
Amended from osv record PYSEC-2026-4336
- Revision 8 · amended ·
Amended from osv record GHSA-654x-cwwv-5j9c
- Revision 7 · amended ·
Amended from osv record PYSEC-2026-4336
- Revision 6 · amended ·
Amended from osv record GHSA-654x-cwwv-5j9c
- Revision 5 · amended ·
Amended from ghsa record GHSA-654x-cwwv-5j9c
- Revision 4 · amended ·
Amended from ghsa record GHSA-654x-cwwv-5j9c
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-654x-cwwv-5j9c
- Revision 1 · created ·
Published from ghsa record GHSA-654x-cwwv-5j9c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114501 Advisory: Pillow: Arrow export leaks stale heap memory when PILLOW_ALIGNMENT > 1 IDs: CVE-2026-114501, GHSA-654x-cwwv-5j9c Record: https://patchnext.com/advisories/cve-2026-114501 (revision 10, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected >= 11.2.1, < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected >= 11.2.1, < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-654x-cwwv-5j9c (GitHub-reviewed advisory GHSA-654x-cwwv-5j9c lists affected ranges: PyPI pillow >=11.2.1 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-654x-cwwv-5j9c (OSV record GHSA-654x-cwwv-5j9c lists affected ranges: PyPI pillow >=11.2.1 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-4336 (OSV record PYSEC-2026-4336 lists affected ranges: PyPI pillow >=11.2.1 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-114501 (OSV record BIT-pillow-2026-114501 lists affected ranges: Bitnami pillow >=11.2.1 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…