Skip to content

← Actionable
Critical, CVSS 9.1amended

Sentry-Javascript: Middleware Bypass when using Tunnel route

CVE-2026-114139GHSA-mchm-gjx6-7h55

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sentry/nextjs 11.0.0-rc.1, 10.75.2, 9.47.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @sentry/nextjs

    Affected
    >= 9.36.0, < 9.47.2>= 10.0.0-alpha.0, < 10.75.2>= 11.0.0-alpha.0, < 11.0.0-rc.1
    Fixed in
    10.75.2, 11.0.0-rc.1, 9.47.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-114139: 0.51% estimated exploitation activity in the next 30 days; percentile 43.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The tunnelRoute option makes the SDK send browser events to a path on your own Next.js server (for example /monitoring), where a rewrite forwards them to Sentry to prevent ad blockers from blocking them. To keep those envelope requests from being rejected by your middleware, the SDK skips middleware for them. The middleware skip was wider than the rewrite. The rewrite only serves requests to the tunnel path itself with the o and p parameters set. The skip applied to anything under the tunnel path. Requests in that gap go to your application instead of Sentry, and your middleware never runs on them. Skipping middleware does not grant the request any privileges. Routes that check the session server-side are still protected. You are affected only if all of the following are true: 1. tunnelRoute is set (a string path or true), 2. your app is built with webpack (Turbopack builds are not affected), 3. some route of your application resolves under the tunnel path. That could be a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from ghsa record GHSA-mchm-gjx6-7h55

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-mchm-gjx6-7h55

  3. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  4. Revision 2 · amended ·

    Amended from osv record GHSA-mchm-gjx6-7h55

  5. Revision 1 · created ·

    Published from ghsa record GHSA-mchm-gjx6-7h55

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114139

Advisory: Sentry-Javascript: Middleware Bypass when using Tunnel route
IDs: CVE-2026-114139, GHSA-mchm-gjx6-7h55
Record: https://patchnext.com/advisories/cve-2026-114139 (revision 5, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sentry/nextjs 11.0.0-rc.1, 10.75.2, 9.47.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sentry/nextjs: affected >= 9.36.0, < 9.47.2; >= 10.0.0-alpha.0, < 10.75.2; >= 11.0.0-alpha.0, < 11.0.0-rc.1; fixed in 10.75.2, 11.0.0-rc.1, 9.47.2

## Suggested inspection (read-only)
- `npm ls @sentry/nextjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sentry/nextjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mchm-gjx6-7h55 (GitHub-reviewed advisory GHSA-mchm-gjx6-7h55 lists affected ranges: npm @sentry/nextjs >=9.36.0 =10.0.0-alpha.0 =11.0.0-alpha.0 <11.0.0-rc.1)
- Verified: https://osv.dev/vulnerability/GHSA-mchm-gjx6-7h55 (OSV record GHSA-mchm-gjx6-7h55 lists affected ranges: npm @sentry/nextjs >=9.36.0 =10.0.0-alpha.0 =11.0.0-alpha.0 <11.0.0-rc.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…