Skip to content

← Actionable
High, CVSS 7.5amended

Django REST framework: JSONParser applies an attacker-named codec to the request stream

CVE-2026-114136GHSA-3547-9m27-7rxg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (djangorestframework 3.18.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-114136: 0.50% estimated exploitation activity in the next 30 days; percentile 43.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated attacker can defeat Django's DATAUPLOADMAXMEMORYSIZE limit and force a worker process to allocate arbitrary memory, by naming a compression codec in the Content-Type charset parameter. A 108-byte request body produces a 50,331,648-character value inside the view, an amplification factor of 466,033, and grows process peak RSS by about 97 MiB. No application configuration is required beyond DRF's default parser set; the endpoint only has to accept a JSON body. Details JSONParser.parse decodes the request body with the charset the client supplied on the Content-Type header: Of the roughly 455 codec names codecs.lookup resolves on CPython 3.14, about 18 are byte transforms instead of character sets: bz2codec, zlibcodec, base64codec, hexcodec, quopricodec, uucodec and similar. codecs.getreader is the only entry point in the codecs module that does not consult CodecInfo.istextencoding, so it accepts all of them. Sending Content-Type: application/json;…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3547-9m27-7rxg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-3547-9m27-7rxg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-3547-9m27-7rxg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114136

Advisory: Django REST framework: JSONParser applies an attacker-named codec to the request stream
IDs: CVE-2026-114136, GHSA-3547-9m27-7rxg
Record: https://patchnext.com/advisories/cve-2026-114136 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: djangorestframework 3.18.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI djangorestframework: affected >= 3.6.4, < 3.18.2; fixed in 3.18.2

## Suggested inspection (read-only)
- `python -m pip show djangorestframework`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on djangorestframework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3547-9m27-7rxg (GitHub-reviewed advisory GHSA-3547-9m27-7rxg lists affected ranges: PyPI djangorestframework >=3.6.4 <3.18.2)
- Verified: https://osv.dev/vulnerability/GHSA-3547-9m27-7rxg (OSV record GHSA-3547-9m27-7rxg lists affected ranges: PyPI djangorestframework >=3.6.4 <3.18.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…